aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kdesignerplugin')
-rw-r--r--kde-frameworks/kdesignerplugin/Manifest1
-rw-r--r--kde-frameworks/kdesignerplugin/kdesignerplugin-5.65.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/kdesignerplugin/Manifest b/kde-frameworks/kdesignerplugin/Manifest
new file mode 100644
index 0000000000..a442b7c05a
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/Manifest
@@ -0,0 +1 @@
+DIST kdesignerplugin-5.65.0.tar.xz 71152 BLAKE2B 733c281b0ca6e67e09adf46583c8a75746eec364586700263d7d02846a8e6189650e79f27729c7ea5fda59d1cb264cde40daba9c45b1b4f55c90ca50ebec0ec4 SHA512 4caf89f2ea2b52697b967d3025217ac49d4dde8b475af8605e5a7a7e7014a7fb1d6da2433e8b3162e33eb1ed85bf8cdcb8c50cf5bb1de1cb9d4243754a90614a
diff --git a/kde-frameworks/kdesignerplugin/kdesignerplugin-5.65.0.ebuild b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.65.0.ebuild
new file mode 100644
index 0000000000..f83e326bda
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.65.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_QTHELP="false"
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing plugins to use KDE frameworks widgets in QtDesigner"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=kde-frameworks/kconfig-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${PVCUT}:5
+"
+RDEPEND="${DEPEND}"