aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.13.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 8d57cbb8f6..ee04ef159f 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1 +1,2 @@
DIST ksysguard-5.13.0.tar.xz 490348 BLAKE2B 49adff54d49d6ff07d1255cb8b92d343addea61a83ef9a3e2fa75367bd28bde3aa5a6187e6f4ad4c47cbcd6d6a89b394f1a7d07aa723d2ff50dfcc8b1ac3e0e5 SHA512 a32ce5d017f461a7b66dd5693e6f512230068819430bc1df34d3a5a4cbdf812b7e0b5e2977a90007a95bf5cfbc69c117ec502a795649999ed9ca9c28685df546
+DIST ksysguard-5.13.1.tar.xz 492960 BLAKE2B cedd8a66b169a7e37995b738d8c2313957621262568a69d4d6c420ca8f08fd6f2b2df6030f6b3246bfb146068bf3b8c3de90d31c56b4fd0f06956e97a1be3f6f SHA512 bde346c77587a8e9b71a50a2426a4f05449e568a566671ae92ed652a5a8f9a2aa2732e27471696ec42ea88a9d65b4a21cc0a026ecbd2977cc72f01ce96d63a22
diff --git a/kde-plasma/ksysguard/ksysguard-5.13.1.ebuild b/kde-plasma/ksysguard/ksysguard-5.13.1.ebuild
new file mode 100644
index 0000000000..5e2260a856
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.13.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}