aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libkgoogle/libkgoogle-0.3.2.ebuild')
-rw-r--r--net-libs/libkgoogle/libkgoogle-0.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libkgoogle/libkgoogle-0.3.2.ebuild b/net-libs/libkgoogle/libkgoogle-0.3.2.ebuild
new file mode 100644
index 0000000000..bf948d590f
--- /dev/null
+++ b/net-libs/libkgoogle/libkgoogle-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Library for accessing various Google services based on KDE Platform"
+HOMEPAGE="http://progdan.cz/category/akonadi-google/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="oldpim"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs semantic-desktop)
+ dev-libs/libxslt
+ dev-libs/qjson
+ oldpim? ( dev-libs/boost )
+ !oldpim? ( $(add_kdebase_dep kdepimlibs semantic-desktop 4.6.0) )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use oldpim KCAL)
+ )
+ kde4-base_src_configure
+}