aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qtweetlib/qtweetlib-9999.ebuild')
-rw-r--r--net-libs/qtweetlib/qtweetlib-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/qtweetlib/qtweetlib-9999.ebuild b/net-libs/qtweetlib/qtweetlib-9999.ebuild
new file mode 100644
index 0000000000..c8cd13d5a0
--- /dev/null
+++ b/net-libs/qtweetlib/qtweetlib-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+# use domme's/dschmidt's clone for now, until the CMake support is merge
+# back to minimoog's original repository. See also:
+# https://github.com/minimoog/QTweetLib/network
+#EGIT_REPO_URI="git://github.com/minimoog/QTweetLib.git"
+EGIT_REPO_URI="git://github.com/dschmidt/QTweetLib.git"
+[[ ${PV} == *9999 ]] && GIT_ECLASS="git-2"
+inherit qt4-r2 cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Qt based Twitter library"
+HOMEPAGE="https://github.com/minimoog/QTweetLib"
+[[ ${PV} == *9999 ]] || SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="debug"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/qjson-0.7.1
+ >=x11-libs/qt-core-4.6.0[ssl]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/"${PN}"