aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2015-10-16 23:19:25 -0400
committerDevan Franchini <twitch153@gentoo.org>2015-10-16 23:19:28 -0400
commit909afd209034ec26bca6f8c5d646852b2bd62c3e (patch)
treeb9d4a7e36c4090abacf1b2febbc047c24e5c8642
parentsetup.py: Closes bracket for database module appending (diff)
downloadlayman-909afd20.tar.gz
layman-909afd20.tar.bz2
layman-909afd20.zip
dbbase.py: Whitespace cleanup
Shamelessly hiding the fact that I'm also ammending the lack of self.db_type use in the remove() function.
-rw-r--r--layman/dbbase.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/layman/dbbase.py b/layman/dbbase.py
index ebcd7a4..c2b25b8 100644
--- a/layman/dbbase.py
+++ b/layman/dbbase.py
@@ -173,8 +173,8 @@ class DbBase(object):
self.output.die(msg)
return db_ctl
-
-
+
+
def add_new(self, xml=None, origin=None, from_dict=None):
'''
Reads xml text and dictionary definitions and adds
@@ -229,7 +229,7 @@ class DbBase(object):
'''
Remove an overlay from the database.
'''
- db_ctl = self._get_dbctl(db_type)
+ db_ctl = self._get_dbctl(self.db_type)
db_ctl.remove(overlay, path)