summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-11-03 13:39:46 -0500
committerMike Pagano <mpagano@gentoo.org>2015-11-03 13:39:46 -0500
commit22cf0359e3a1f6a2406230bdd75bb7a63c3212d0 (patch)
tree4435dde04759fb7c75f4e2430dfae94f332205d7
parentLinux patch 3.18.23 (diff)
downloadlinux-patches-22cf0359.tar.gz
linux-patches-22cf0359.tar.bz2
linux-patches-22cf0359.zip
Linux patch 3.18.243.18-24
-rw-r--r--0000_README4
-rw-r--r--1023_linux-3.18.24.patch24
2 files changed, 28 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 84e11a60..d8298235 100644
--- a/0000_README
+++ b/0000_README
@@ -135,6 +135,10 @@ Patch: 1022_linux-3.18.23.patch
From: http://www.kernel.org
Desc: Linux 3.18.23
+Patch: 1023_linux-3.18.24.patch
+From: http://www.kernel.org
+Desc: Linux 3.18.24
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1023_linux-3.18.24.patch b/1023_linux-3.18.24.patch
new file mode 100644
index 00000000..bed3a752
--- /dev/null
+++ b/1023_linux-3.18.24.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index 2ebc49903d33..9769e3bce6a2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 3
+ PATCHLEVEL = 18
+-SUBLEVEL = 23
++SUBLEVEL = 24
+ EXTRAVERSION =
+ NAME = Diseased Newt
+
+diff --git a/drivers/tty/n_tty.c b/drivers/tty/n_tty.c
+index fea7d905e77c..04e7d8e38c53 100644
+--- a/drivers/tty/n_tty.c
++++ b/drivers/tty/n_tty.c
+@@ -364,7 +364,6 @@ static void n_tty_packet_mode_flush(struct tty_struct *tty)
+ spin_lock_irqsave(&tty->ctrl_lock, flags);
+ if (tty->link->packet) {
+ tty->ctrl_status |= TIOCPKT_FLUSHREAD;
+- spin_unlock_irqrestore(&tty->ctrl_lock, flags);
+ wake_up_interruptible(&tty->link->read_wait);
+ }
+ spin_unlock_irqrestore(&tty->ctrl_lock, flags);