summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-05-30 18:32:53 -0400
committerMike Pagano <mpagano@gentoo.org>2018-05-30 18:32:53 -0400
commit261a8d3776a053c2625797b867d00d9e978b3a0a (patch)
tree192fc06029ae7f69cbc100713901bd46639ff719
parentLinux patches 4.14.45 and 4.14.46 (diff)
downloadlinux-patches-261a8d37.tar.gz
linux-patches-261a8d37.tar.bz2
linux-patches-261a8d37.zip
Linux patch 4.14.474.14-51
-rw-r--r--0000_README4
-rw-r--r--1046_linux-4.14.47.patch25
2 files changed, 29 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 63dde0ea..7a38d723 100644
--- a/0000_README
+++ b/0000_README
@@ -227,6 +227,10 @@ Patch: 1045_linux-4.14.46.patch
From: http://www.kernel.org
Desc: Linux 4.14.46
+Patch: 1046_linux-4.14.47.patch
+From: http://www.kernel.org
+Desc: Linux 4.14.47
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1046_linux-4.14.47.patch b/1046_linux-4.14.47.patch
new file mode 100644
index 00000000..ded7b4e1
--- /dev/null
+++ b/1046_linux-4.14.47.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 3b1845f2b8f8..d6db01a02252 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 4
+ PATCHLEVEL = 14
+-SUBLEVEL = 46
++SUBLEVEL = 47
+ EXTRAVERSION =
+ NAME = Petit Gorille
+
+diff --git a/net/ipv4/ip_vti.c b/net/ipv4/ip_vti.c
+index 5c5699c08575..00d4371d4573 100644
+--- a/net/ipv4/ip_vti.c
++++ b/net/ipv4/ip_vti.c
+@@ -396,6 +396,7 @@ static int vti_tunnel_init(struct net_device *dev)
+ memcpy(dev->dev_addr, &iph->saddr, 4);
+ memcpy(dev->broadcast, &iph->daddr, 4);
+
++ dev->mtu = ETH_DATA_LEN;
+ dev->flags = IFF_NOARP;
+ dev->addr_len = 4;
+ dev->features |= NETIF_F_LLTX;