summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-10-07 06:37:37 -0400
committerMike Pagano <mpagano@gentoo.org>2021-10-07 06:37:37 -0400
commit306c1eb871bec43d64a373d15332875f6599aeaa (patch)
tree2115d6ed4e1336d26d5c9bc1faef034657e615cf
parentLinux patch 4.4.286 (diff)
downloadlinux-patches-306c1eb8.tar.gz
linux-patches-306c1eb8.tar.bz2
linux-patches-306c1eb8.zip
Linux patch 4.4.2874.4-289
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1286_linux-4.4.287.patch25
2 files changed, 29 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 9700d523..7389c236 100644
--- a/0000_README
+++ b/0000_README
@@ -1187,6 +1187,10 @@ Patch: 1285_linux-4.4.286.patch
From: http://www.kernel.org
Desc: Linux 4.4.286
+Patch: 1286_linux-4.4.287.patch
+From: http://www.kernel.org
+Desc: Linux 4.4.287
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1286_linux-4.4.287.patch b/1286_linux-4.4.287.patch
new file mode 100644
index 00000000..9abc40cf
--- /dev/null
+++ b/1286_linux-4.4.287.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 34ad8ef93d409..fc14cb0bf5e0d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 4
+-SUBLEVEL = 286
++SUBLEVEL = 287
+ EXTRAVERSION =
+ NAME = Blurry Fish Butt
+
+diff --git a/arch/arm64/kernel/process.c b/arch/arm64/kernel/process.c
+index 6cd79888944e6..10d6627673cbf 100644
+--- a/arch/arm64/kernel/process.c
++++ b/arch/arm64/kernel/process.c
+@@ -55,7 +55,7 @@
+
+ #ifdef CONFIG_CC_STACKPROTECTOR
+ #include <linux/stackprotector.h>
+-unsigned long __stack_chk_guard __ro_after_init;
++unsigned long __stack_chk_guard __read_mostly;
+ EXPORT_SYMBOL(__stack_chk_guard);
+ #endif
+