summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-12-11 09:18:57 -0500
committerMike Pagano <mpagano@gentoo.org>2023-12-11 09:18:57 -0500
commit46aed29aa002a2e1749a3c2c051333bb86ccf53f (patch)
tree24f340a849f7429a11ad72a4fd045d0859f193e3
parentRemove redundant patch (diff)
downloadlinux-patches-46aed29a.tar.gz
linux-patches-46aed29a.tar.bz2
linux-patches-46aed29a.zip
Linux patch 6.6.66.6-8
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1005_linux-6.6.6.patch122
2 files changed, 126 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 5f653f8c..5f6d8661 100644
--- a/0000_README
+++ b/0000_README
@@ -63,6 +63,10 @@ Patch: 1004_linux-6.6.5.patch
From: https://www.kernel.org
Desc: Linux 6.6.5
+Patch: 1005_linux-6.6.6.patch
+From: https://www.kernel.org
+Desc: Linux 6.6.6
+
Patch: 1510_fs-enable-link-security-restrictions-by-default.patch
From: http://sources.debian.net/src/linux/3.16.7-ckt4-3/debian/patches/debian/fs-enable-link-security-restrictions-by-default.patch/
Desc: Enable link security restrictions by default.
diff --git a/1005_linux-6.6.6.patch b/1005_linux-6.6.6.patch
new file mode 100644
index 00000000..7339aa3d
--- /dev/null
+++ b/1005_linux-6.6.6.patch
@@ -0,0 +1,122 @@
+diff --git a/Makefile b/Makefile
+index ee4e504a3e78e..1eefa893f048b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 6
+ PATCHLEVEL = 6
+-SUBLEVEL = 5
++SUBLEVEL = 6
+ EXTRAVERSION =
+ NAME = Hurr durr I'ma ninja sloth
+
+diff --git a/net/wireless/core.h b/net/wireless/core.h
+index f0a3a23176385..e536c0b615a09 100644
+--- a/net/wireless/core.h
++++ b/net/wireless/core.h
+@@ -299,7 +299,6 @@ struct cfg80211_cqm_config {
+ u32 rssi_hyst;
+ s32 last_rssi_event_value;
+ enum nl80211_cqm_rssi_threshold_event last_rssi_event_type;
+- bool use_range_api;
+ int n_rssi_thresholds;
+ s32 rssi_thresholds[] __counted_by(n_rssi_thresholds);
+ };
+diff --git a/net/wireless/nl80211.c b/net/wireless/nl80211.c
+index 6a82dd876f278..931a03f4549c9 100644
+--- a/net/wireless/nl80211.c
++++ b/net/wireless/nl80211.c
+@@ -12824,6 +12824,10 @@ static int cfg80211_cqm_rssi_update(struct cfg80211_registered_device *rdev,
+ int i, n, low_index;
+ int err;
+
++ /* RSSI reporting disabled? */
++ if (!cqm_config)
++ return rdev_set_cqm_rssi_range_config(rdev, dev, 0, 0);
++
+ /*
+ * Obtain current RSSI value if possible, if not and no RSSI threshold
+ * event has been received yet, we should receive an event after a
+@@ -12898,6 +12902,18 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
+ wdev->iftype != NL80211_IFTYPE_P2P_CLIENT)
+ return -EOPNOTSUPP;
+
++ if (n_thresholds <= 1 && rdev->ops->set_cqm_rssi_config) {
++ if (n_thresholds == 0 || thresholds[0] == 0) /* Disabling */
++ return rdev_set_cqm_rssi_config(rdev, dev, 0, 0);
++
++ return rdev_set_cqm_rssi_config(rdev, dev,
++ thresholds[0], hysteresis);
++ }
++
++ if (!wiphy_ext_feature_isset(&rdev->wiphy,
++ NL80211_EXT_FEATURE_CQM_RSSI_LIST))
++ return -EOPNOTSUPP;
++
+ if (n_thresholds == 1 && thresholds[0] == 0) /* Disabling */
+ n_thresholds = 0;
+
+@@ -12905,20 +12921,6 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
+ old = rcu_dereference_protected(wdev->cqm_config,
+ lockdep_is_held(&wdev->mtx));
+
+- /* if already disabled just succeed */
+- if (!n_thresholds && !old)
+- return 0;
+-
+- if (n_thresholds > 1) {
+- if (!wiphy_ext_feature_isset(&rdev->wiphy,
+- NL80211_EXT_FEATURE_CQM_RSSI_LIST) ||
+- !rdev->ops->set_cqm_rssi_range_config)
+- return -EOPNOTSUPP;
+- } else {
+- if (!rdev->ops->set_cqm_rssi_config)
+- return -EOPNOTSUPP;
+- }
+-
+ if (n_thresholds) {
+ cqm_config = kzalloc(struct_size(cqm_config, rssi_thresholds,
+ n_thresholds),
+@@ -12933,26 +12935,13 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
+ memcpy(cqm_config->rssi_thresholds, thresholds,
+ flex_array_size(cqm_config, rssi_thresholds,
+ n_thresholds));
+- cqm_config->use_range_api = n_thresholds > 1 ||
+- !rdev->ops->set_cqm_rssi_config;
+
+ rcu_assign_pointer(wdev->cqm_config, cqm_config);
+-
+- if (cqm_config->use_range_api)
+- err = cfg80211_cqm_rssi_update(rdev, dev, cqm_config);
+- else
+- err = rdev_set_cqm_rssi_config(rdev, dev,
+- thresholds[0],
+- hysteresis);
+ } else {
+ RCU_INIT_POINTER(wdev->cqm_config, NULL);
+- /* if enabled as range also disable via range */
+- if (old->use_range_api)
+- err = rdev_set_cqm_rssi_range_config(rdev, dev, 0, 0);
+- else
+- err = rdev_set_cqm_rssi_config(rdev, dev, 0, 0);
+ }
+
++ err = cfg80211_cqm_rssi_update(rdev, dev, cqm_config);
+ if (err) {
+ rcu_assign_pointer(wdev->cqm_config, old);
+ kfree_rcu(cqm_config, rcu_head);
+@@ -19142,11 +19131,10 @@ void cfg80211_cqm_rssi_notify_work(struct wiphy *wiphy, struct wiphy_work *work)
+ wdev_lock(wdev);
+ cqm_config = rcu_dereference_protected(wdev->cqm_config,
+ lockdep_is_held(&wdev->mtx));
+- if (!cqm_config)
++ if (!wdev->cqm_config)
+ goto unlock;
+
+- if (cqm_config->use_range_api)
+- cfg80211_cqm_rssi_update(rdev, wdev->netdev, cqm_config);
++ cfg80211_cqm_rssi_update(rdev, wdev->netdev, cqm_config);
+
+ rssi_level = cqm_config->last_rssi_event_value;
+ rssi_event = cqm_config->last_rssi_event_type;