summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-05-02 15:24:33 -0400
committerMike Pagano <mpagano@gentoo.org>2020-05-02 15:24:33 -0400
commit5ab7e7f6ccca46d47ce7246f8086bc385244315a (patch)
tree7ee816351130cc82f6929a35a9df1f197d9a1a81
parentLinux patch 5.4.37 (diff)
downloadlinux-patches-5ab7e7f6.tar.gz
linux-patches-5ab7e7f6.tar.bz2
linux-patches-5ab7e7f6.zip
Linux patch 5.4.385.4-38
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1037_linux-5.4.38.patch29
2 files changed, 33 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 0cb47e84..8f9e369b 100644
--- a/0000_README
+++ b/0000_README
@@ -191,6 +191,10 @@ Patch: 1036_linux-5.4.37.patch
From: http://www.kernel.org
Desc: Linux 5.4.37
+Patch: 1037_linux-5.4.38.patch
+From: http://www.kernel.org
+Desc: Linux 5.4.38
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1037_linux-5.4.38.patch b/1037_linux-5.4.38.patch
new file mode 100644
index 00000000..2bd282e6
--- /dev/null
+++ b/1037_linux-5.4.38.patch
@@ -0,0 +1,29 @@
+diff --git a/Makefile b/Makefile
+index 33690285d6aa..989e7d649633 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 4
+-SUBLEVEL = 37
++SUBLEVEL = 38
+ EXTRAVERSION =
+ NAME = Kleptomaniac Octopus
+
+diff --git a/sound/soc/meson/axg-card.c b/sound/soc/meson/axg-card.c
+index 2b04ac3d8fd3..1f698adde506 100644
+--- a/sound/soc/meson/axg-card.c
++++ b/sound/soc/meson/axg-card.c
+@@ -586,10 +586,8 @@ static int axg_card_add_link(struct snd_soc_card *card, struct device_node *np,
+
+ if (axg_card_cpu_is_tdm_iface(dai_link->cpus->of_node))
+ ret = axg_card_parse_tdm(card, np, index);
+- else if (axg_card_cpu_is_codec(dai_link->cpus->of_node)) {
++ else if (axg_card_cpu_is_codec(dai_link->cpus->of_node))
+ dai_link->params = &codec_params;
+- dai_link->no_pcm = 0; /* link is not a DPCM BE */
+- }
+
+ return ret;
+ }