summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2017-12-29 17:47:45 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2017-12-29 17:47:45 +0000
commitb55625787f4784059c04614dd2411457decd3788 (patch)
tree47be89038d23fd8ddd0d9e1d515815fb3a88897b
parentlinux kernel 4.14.10 (diff)
downloadlinux-patches-b5562578.tar.gz
linux-patches-b5562578.tar.bz2
linux-patches-b5562578.zip
patch(1) loses the x bit. Kernel build breaks.4.14-12
-rw-r--r--0000_README4
-rw-r--r--2901_tools-objtool-makefile-dont-assume-sync-checksh-is-executable.patch25
2 files changed, 29 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index e43b606a..91111871 100644
--- a/0000_README
+++ b/0000_README
@@ -115,6 +115,10 @@ Patch: 2900_dev-root-proc-mount-fix.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=438380
Desc: Ensure that /dev/root doesn't appear in /proc/mounts when bootint without an initramfs.
+Patch: 2901_tools-objtool-makefile-dont-assume-sync-checksh-is-executable.patch
+From: http://www.ozlabs.org/~akpm/mmotm/broken-out/tools-objtool-makefile-dont-assume-sync-checksh-is-executable.patch
+Desc: patch(1) loses the x bit. Kernel build breaks.
+
Patch: 4200_fbcondecor.patch
From: http://www.mepiscommunity.org/fbcondecor
Desc: Bootsplash ported by Conrad Kostecki. (Bug #637434)
diff --git a/2901_tools-objtool-makefile-dont-assume-sync-checksh-is-executable.patch b/2901_tools-objtool-makefile-dont-assume-sync-checksh-is-executable.patch
new file mode 100644
index 00000000..3199be9b
--- /dev/null
+++ b/2901_tools-objtool-makefile-dont-assume-sync-checksh-is-executable.patch
@@ -0,0 +1,25 @@
+From: Andrew Morton <akpm@linux-foundation.org>
+Subject: tools/objtool/Makefile: don't assume sync-check.sh is executable
+
+patch(1) loses the x bit. Kernel build breaks.
+
+Fixes: 3bd51c5a371de ("objtool: Move kernel headers/code sync check to a script")
+Cc: Ingo Molnar <mingo@kernel.org>
+Cc: Josh Poimboeuf <jpoimboe@redhat.com>
+Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
+---
+
+
+diff -puN tools/objtool/Makefile~tools-objtool-makefile-dont-assume-sync-checksh-is-executable tools/objtool/Makefile
+--- a/tools/objtool/Makefile~tools-objtool-makefile-dont-assume-sync-checksh-is-executable
++++ a/tools/objtool/Makefile
+@@ -46,7 +46,7 @@ $(OBJTOOL_IN): fixdep FORCE
+ @$(MAKE) $(build)=objtool
+
+ $(OBJTOOL): $(LIBSUBCMD) $(OBJTOOL_IN)
+- @./sync-check.sh
++ @$(CONFIG_SHELL) ./sync-check.sh
+ $(QUIET_LINK)$(CC) $(OBJTOOL_IN) $(LDFLAGS) -o $@
+
+
+_