summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '1183_linux-4.4.184.patch')
-rw-r--r--1183_linux-4.4.184.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/1183_linux-4.4.184.patch b/1183_linux-4.4.184.patch
new file mode 100644
index 00000000..3f085a56
--- /dev/null
+++ b/1183_linux-4.4.184.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 4ac762e01e60..f098274d3ac3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 4
+-SUBLEVEL = 183
++SUBLEVEL = 184
+ EXTRAVERSION =
+ NAME = Blurry Fish Butt
+
+diff --git a/net/ipv4/tcp_output.c b/net/ipv4/tcp_output.c
+index bed83990847a..53edd60fd381 100644
+--- a/net/ipv4/tcp_output.c
++++ b/net/ipv4/tcp_output.c
+@@ -1161,7 +1161,7 @@ int tcp_fragment(struct sock *sk, struct sk_buff *skb, u32 len,
+ if (nsize < 0)
+ nsize = 0;
+
+- if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf)) {
++ if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf + 0x20000)) {
+ NET_INC_STATS(sock_net(sk), LINUX_MIB_TCPWQUEUETOOBIG);
+ return -ENOMEM;
+ }