summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-03-23 17:39:48 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-23 17:39:48 +0100
commita01793174319588a4f470c59495bc9ec80ecbb04 (patch)
treedc5ae65f22e401bb2bb4125438841d7fe219a4ca
parentdev-lisp/usocket: Removes 0.6 versions (diff)
downloadlisp-a01793174319588a4f470c59495bc9ec80ecbb04.tar.gz
lisp-a01793174319588a4f470c59495bc9ec80ecbb04.tar.bz2
lisp-a01793174319588a4f470c59495bc9ec80ecbb04.zip
x11-wm/stumpwm-contrib: New snapshot ebuild
-rw-r--r--x11-wm/stumpwm-contrib/Manifest2
-rw-r--r--x11-wm/stumpwm-contrib/stumpwm-contrib-20180323.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-wm/stumpwm-contrib/Manifest b/x11-wm/stumpwm-contrib/Manifest
index 6d4106df..0481f870 100644
--- a/x11-wm/stumpwm-contrib/Manifest
+++ b/x11-wm/stumpwm-contrib/Manifest
@@ -1,4 +1,6 @@
DIST stumpwm-contrib-20180128.tar.bz2 575171 BLAKE2B 57f5cab26ecfd0721ae3c167ad09922920b171fc95250eb6e98936033623837d50d70179a2262093b4db978477da3ae0bc5e920ac0cfc1e291f60ef6b7c0c260 SHA512 76bc7bf0b5a752264f3719d38773362cf134edb8ce128d2213a0d636485d12ae86b52d111d07688ce0b2a97e1e4282b391491a738e77946d225ddc22c84e8156
+DIST stumpwm-contrib-20180323.tar.bz2 577707 BLAKE2B 1dc55aee1009aceb2e8297d66cb9c3f3ca39b859287226f42250a4ae92fa1c7dfc913d54b6e1e61631bac60a751574c54a2ba0b81f2e3993707df2bdcecdc5d0 SHA512 d62229283dd879a9f7962abc99122bcfd920ab02c5f17627c5ff67bc2d34587564c0c66478d2ba367b8e757280a4d72f385cb7a41e0a2df92ce28ec62a885ea0
EBUILD stumpwm-contrib-20180128.ebuild 681 BLAKE2B 0fed95f3c3636d1de908f2134347fca5a76a65551011aefe7ad6e0042b8916a66b0110d55794fcb4537cb4975746bf508e0e4ee0b4fc4866e48ba7c2a6bec0ea SHA512 cd7bfcc3726e5a5c383dadb050df148ee43bde861fd89032381f97a2ebaaa95e52550bb74600af8d4b22c28fe7093c6db9d9267d8875b93cecde82b090fbfeed
+EBUILD stumpwm-contrib-20180323.ebuild 820 BLAKE2B ab1bbf77a3bd1307214087a01d12478c6ebe42b4b21d8b7f319a94ca3d338e8d601b7158de17247f2dd32a46c1820d8c789b79e88297d09a3995875716fe12eb SHA512 44f2251a1adced2837dea49c8c22296867005a550b2403161374acaa018acaf2943e129e361ee8d2c9f663d31cbfaf628b18472e10ee2bb95eeb040fde719626
EBUILD stumpwm-contrib-99999999.ebuild 681 BLAKE2B b46d5d8ec9d506bd4d10512d5d1a654be412c1cad376fa032f570ca8557f7d9e6a64d604e5dc1d5f7c40af30c8789a1ce85b5e716a1626a57d851eb5f12d0293 SHA512 19486f03d44f5ae244b660a465b309a8b39d6ae8ee86945e46db7a8e4760656ea41857f7278c3bcfa6969b50b5ea159a4c131b450a489d1dd9e045abc0b9440b
MISC metadata.xml 338 BLAKE2B cbdb81d444e64f756cf46ef76fc108896defaab4b6ae0cbe2950515e00a0f3874875d52c82d31b32d090aa0d628e2c522b71b6a72519ea33ec5eca630af4875c SHA512 d662b61f41f064ce5fb100324aec996c0956736c9a56f797a2522bb5a1ac7731eec1792d72aa11e85bdb162d7f3b345f8d06540c7452b34bf3064febc1136f64
diff --git a/x11-wm/stumpwm-contrib/stumpwm-contrib-20180323.ebuild b/x11-wm/stumpwm-contrib/stumpwm-contrib-20180323.ebuild
new file mode 100644
index 00000000..7ef1c4b8
--- /dev/null
+++ b/x11-wm/stumpwm-contrib/stumpwm-contrib-20180323.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="Extension Modules for StumpWM"
+HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-3 BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-wm/stumpwm-1.0.0
+ dev-lisp/clx-truetype
+ dev-lisp/drakma
+ dev-lisp/ironclad
+ dev-lisp/percent-encoding
+ dev-lisp/usocket
+ dev-lisp/xkeyboard
+ dev-lisp/zpng"
+
+CONTRIBCATEGORIES="media minor-mode modeline util"
+
+src_install() {
+ common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
+ dobin util/stumpish/stumpish
+ dobin util/pinentry/stumpwm-pinentry
+ dodoc README.org
+}