summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyprien Nicolas (fulax) <gentoo@fulax.fr>2019-06-16 17:25:53 +0200
committerCyprien Nicolas (fulax) <gentoo@fulax.fr>2019-06-16 17:25:53 +0200
commitd7f036035ff474032d277484cbdb33225328d8d9 (patch)
treead97513aae3b7515fa2e9f408fd5b892d596064a /dev-scheme/guile/guile-2.2.4-r1.ebuild
parentdev-lisp/clisp: Drop 2.49.92 (stable in tree); Add -9999 (diff)
downloadlisp-d7f036035ff474032d277484cbdb33225328d8d9.tar.gz
lisp-d7f036035ff474032d277484cbdb33225328d8d9.tar.bz2
lisp-d7f036035ff474032d277484cbdb33225328d8d9.zip
dev-scheme/guile: SLOT, EAPI7, add pre-3.0 releases, cleanup
app-admin/eselect-guile: Drop package package.mask: Update masks for guile
Diffstat (limited to 'dev-scheme/guile/guile-2.2.4-r1.ebuild')
-rw-r--r--dev-scheme/guile/guile-2.2.4-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-scheme/guile/guile-2.2.4-r1.ebuild b/dev-scheme/guile/guile-2.2.4-r1.ebuild
new file mode 100644
index 00000000..8a2a06f1
--- /dev/null
+++ b/dev-scheme/guile/guile-2.2.4-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MAJOR="2.2"
+DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
+HOMEPAGE="https://www.gnu.org/software/guile/"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="2.2/2.2-1" # libguile-2.2.so.1 => 2.2-1
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug debug-malloc +deprecated +networking +nls +regex +threads" # upstream recommended +networking +nls
+REQUIRED_USE="regex" # workaround for bug 596322
+RESTRICT="strip"
+
+RDEPEND="
+ >=dev-libs/boehm-gc-7.0:=[threads?]
+ dev-libs/gmp:=
+ virtual/libffi:=
+ dev-libs/libltdl:=
+ dev-libs/libunistring:0=
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/libtool
+ sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${PN}-2.2.3-gentoo-sandbox.patch" )
+DOCS=( GUILE-VERSION HACKING README )
+
+src_configure() {
+ # see bug #178499
+ filter-flags -ftree-vectorize
+
+ econf \
+ --program-suffix="-${MAJOR}" \
+ --infodir="${EPREFIX}"/usr/share/info/guile-${MAJOR} \
+ --disable-error-on-warning \
+ --disable-rpath \
+ --disable-static \
+ --enable-posix \
+ --without-libgmp-prefix \
+ --without-libiconv-prefix \
+ --without-libintl-prefix \
+ --without-libltdl-prefix \
+ --without-libreadline-prefix \
+ --without-libunistring-prefix \
+ $(use_enable debug guile-debug) \
+ $(use_enable debug-malloc) \
+ $(use_enable deprecated) \
+ $(use_enable networking) \
+ $(use_enable nls) \
+ $(use_enable regex) \
+ $(use_with threads)
+}
+
+src_install() {
+ default
+
+ # Maybe there is a proper way to do this? Symlink handled by eselect
+ mv "${ED}"/usr/share/aclocal/guile.m4 "${ED}"/usr/share/aclocal/guile-${MAJOR}.m4 || die "rename of guile.m4 failed"
+
+ # From Novell
+ # https://bugzilla.novell.com/show_bug.cgi?id=874028#c0
+ dodir /usr/share/gdb/auto-load/$(get_libdir)
+ mv "${ED}"/usr/$(get_libdir)/libguile-*-gdb.scm "${ED}"/usr/share/gdb/auto-load/$(get_libdir) || die
+
+ # necessary for registering slib, see bug 206896
+ keepdir /usr/share/guile/site
+
+ find "${D}" -name '*.la' -delete || die
+}