summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2015-10-03 05:20:51 +0600
committerVadim A. Misbakh-Soloviov <git@mva.name>2015-10-03 05:20:51 +0600
commitecc5995097fcecc06aa4794013659dd5cd48415d (patch)
treeb5b942779cf18694de0de7556539e5002cb9127d /dev-lua/resty-dns
parentsome more porting (diff)
downloadlua-ecc5995097fcecc06aa4794013659dd5cd48415d.tar.gz
lua-ecc5995097fcecc06aa4794013659dd5cd48415d.tar.bz2
lua-ecc5995097fcecc06aa4794013659dd5cd48415d.zip
Finished porting to lua.eclass
Signed-off-by: Vadim A. Misbakh-Soloviov <git@mva.name>
Diffstat (limited to 'dev-lua/resty-dns')
-rw-r--r--dev-lua/resty-dns/resty-dns-9999.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/dev-lua/resty-dns/resty-dns-9999.ebuild b/dev-lua/resty-dns/resty-dns-9999.ebuild
index 8261dd6..5a7d23c 100644
--- a/dev-lua/resty-dns/resty-dns-9999.ebuild
+++ b/dev-lua/resty-dns/resty-dns-9999.ebuild
@@ -4,10 +4,11 @@
EAPI="5"
-inherit eutils toolchain-funcs git-r3
+VCS="git-r3"
+inherit lua
DESCRIPTION="Lua DNS resolver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/openresty/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-resty-dns"
SRC_URI=""
EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
@@ -15,24 +16,18 @@ EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="luajit"
+IUSE=""
RDEPEND="
- virtual/lua[luajit=]
+ virtual/lua[bit]
www-servers/nginx[nginx_modules_http_lua]
"
DEPEND="
${RDEPEND}
- virtual/pkgconfig
"
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
+READMES=( README.markdown )
- sed -r \
- -e "s#^(PREFIX).*#\1=/usr#" \
- -e "s#^(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "s#^(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
+each_lua_install() {
+ dolua lib/resty
}