summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/lua-htmlparser/lua-htmlparser-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/lua-htmlparser/lua-htmlparser-9999.ebuild b/dev-lua/lua-htmlparser/lua-htmlparser-9999.ebuild
new file mode 100644
index 0000000..95af270
--- /dev/null
+++ b/dev-lua/lua-htmlparser/lua-htmlparser-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI=5
+
+inherit toolchain-funcs eutils git-r3
+
+DESCRIPTION="Parse HTML text into a tree of elements with selectors"
+HOMEPAGE="https://github.com/wscherphof/lua-htmlparser"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/wscherphof/lua-htmlparser"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="luajit"
+
+DEPEND="
+ virtual/lua[luajit=]
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_install() {
+ local lua="lua";
+ use luajit && lua="luajit";
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins -r src/*
+}