summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-idn/lua-idn-9999.ebuild')
-rw-r--r--dev-lua/lua-idn/lua-idn-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/lua-idn/lua-idn-9999.ebuild b/dev-lua/lua-idn/lua-idn-9999.ebuild
new file mode 100644
index 0000000..398303b
--- /dev/null
+++ b/dev-lua/lua-idn/lua-idn-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+VCS="git-r3"
+inherit lua
+
+DESCRIPTION="A Lua implementation of Internationalizing Domain Names in Applications (RFC 3490)"
+HOMEPAGE="https://github.com/haste/lua-idn"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/haste/lua-idn"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+# TODO: Lua 5.2 handling
+
+DEPEND="
+ ${RDEPEND}
+"
+
+each_lua_test() {
+ ${LUA} tests.lua
+}
+
+each_lua_install() {
+ dolua idn.lua
+}