summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/mari0/mari0-1.6.ebuild')
-rw-r--r--games-arcade/mari0/mari0-1.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-arcade/mari0/mari0-1.6.ebuild b/games-arcade/mari0/mari0-1.6.ebuild
new file mode 100644
index 0000000..b1fe6b1
--- /dev/null
+++ b/games-arcade/mari0/mari0-1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit eutils games
+
+DESCRIPTION="A mix from Nintendo's Super Mario Bros and Valve's Portal"
+HOMEPAGE="http://stabyourself.net/${PN}/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}-1006/${PN}-source.zip -> ${P}.zip"
+LICENSE="CCPL-Attribution-ShareAlike-NonCommercial-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT=""
+
+RDEPEND=">=games-engines/love-0.8.0
+ media-libs/devil[gif,png]"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ mv "${P/-/_}.love" "${P}.zip"
+ unpack "./${P}.zip"
+ rm "${P}.zip"
+}
+
+src_prepare() {
+ default
+ epatch_user
+}
+
+src_install() {
+ local dir="${GAMES_DATADIR}/love/${PN}"
+ insinto "${dir}"
+ doins -r .
+ doins -s scalable "${FILESDIR}/${PN}.svg"
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
+ make_desktop_entry "${PN}"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ elog "${PN} savegames and configurations are stored in:"
+ elog "~/.local/share/love/${PN}/"
+}