summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/m68k-sources/m68k-sources-2.6.9999.ebuild')
-rw-r--r--sys-kernel/m68k-sources/m68k-sources-2.6.9999.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/sys-kernel/m68k-sources/m68k-sources-2.6.9999.ebuild b/sys-kernel/m68k-sources/m68k-sources-2.6.9999.ebuild
index 3e326a7..fea9ee4 100644
--- a/sys-kernel/m68k-sources/m68k-sources-2.6.9999.ebuild
+++ b/sys-kernel/m68k-sources/m68k-sources-2.6.9999.ebuild
@@ -10,10 +10,11 @@ RC=${PVR##*_}
KV_BASE=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}
KV_MOD=${KV_FULL##*-}
-KV_MAIN="linux-${KV_MOD}"
-EGIT_PROJECT="linux-${KV_FULL}"
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/geert/${KV_MAIN}"
+KV_MAIN="${KV_MOD}-v${KV_BASE}"
+EGIT_PROJECT="linux-${KV_MOD}.git"
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/geert/${EGIT_PROJECT}"
EGIT_BRANCH="master"
+EGIT_TREE="${EGIT_BRANCH}"
HOMEPAGE="http://www.linux-m68k.org/"
DESCRIPTION="m68k 2.6.29 git kernel sources"
@@ -33,16 +34,16 @@ report the problem so it can be fixed in time for the next kernel release."
src_unpack() {
git_src_unpack
- cd "${EGIT_STORE_DIR}/${EGIT_PROJECT}"
- local last_commit_abbrev=$(git log -n 1 --no-color --pretty='format:%h')
-
- EXTRAVERSION="-${KV_MOD}.git-${last_commit_abbrev}"
-
- S=${WORKDIR}/${EGIT_PROJECT}
-
- cd "${S}"
-
- unpack_set_extraversion
+# cd "${EGIT_STORE_DIR}/${EGIT_PROJECT}"
+# local last_commit_abbrev=$(git log -n 1 --no-color --pretty='format:%h')
+#
+# EXTRAVERSION="-${KV_MOD}.git-${last_commit_abbrev}"
+#
+# S=${WORKDIR}/${EGIT_PROJECT}
+#
+# cd "${S}"
+#
+# unpack_set_extraversion
}
pkg_postinst() {