aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-05-04 23:02:53 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-05-04 23:02:53 -0400
commit470f7cb82169d76ea8d463c212aa08e866dad3fb (patch)
tree4f6c8f1f39745e953a2cd6f734a8277f9a784368
parentAdd script to help automate rolling of langpacks for mozilla packages (diff)
downloadmozilla-470f7cb8.tar.gz
mozilla-470f7cb8.tar.bz2
mozilla-470f7cb8.zip
minor adjustments to two scripts
Added logic to abort if the ebuild specified as argument to generate_langpacks.sh doesn't exist (typo in the path, etc) Added another case to the MOZ_ESR check in verify_distfiles.sh to match properly in older thunderbird-bin ebuilds
-rwxr-xr-xscripts/generate_langpacks.sh2
-rwxr-xr-xscripts/verify_distfiles.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/scripts/generate_langpacks.sh b/scripts/generate_langpacks.sh
index 5032cdd1..bbeb745c 100755
--- a/scripts/generate_langpacks.sh
+++ b/scripts/generate_langpacks.sh
@@ -21,7 +21,7 @@ fi
ebuild=${1}
-if [[ ${ebuild/.ebuild/} == ${ebuild} ]]; then
+if [[ ${ebuild/.ebuild/} == ${ebuild} ]] || [[ ! -e ${ebuild} ]]; then
echo "Must specify the full path to the ebuild as arg.1"
fi
diff --git a/scripts/verify_distfiles.sh b/scripts/verify_distfiles.sh
index 0cf2d689..d7fe77d4 100755
--- a/scripts/verify_distfiles.sh
+++ b/scripts/verify_distfiles.sh
@@ -9,7 +9,7 @@ check_distfiles() {
local myver myname tmp
myname=$(qatom $1 |awk '{print $2}')
mybasename=${myname/-bin/}
- if grep 'MOZ_ESR=""' $1 &>/dev/null || [[ -n $(grep -L MOZ_ESR $1) ]] ; then
+ if grep -e 'MOZ_ESR=""' -e 'MOZ_ESR="0"' $1 &>/dev/null || [[ -n $(grep -L MOZ_ESR $1) ]] ; then
myver=$(qatom $1 |awk '{print $3}')
else
myver=$(qatom $1 |awk '{print $3 "esr"}')