aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-07-12 15:41:51 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-07-12 15:41:51 -0400
commit9d752a3e18cf6b4d928f4e1ffba67c44058b785f (patch)
tree4db8239b1a5a3ebce5dc5b4b1d74eef41e79da84
parentmozlinguas-v2.eclass: minor adjustments (diff)
downloadmozilla-9d752a3e.tar.gz
mozilla-9d752a3e.tar.bz2
mozilla-9d752a3e.zip
www-client/seamonkey - fix locale generation issue when chatzilla is not enabled
Although the build of chatzilla can be enabled or disabled via the useflag, upstream's build system for the locales had no such conditional and so failed if chatzilla wasn't built. This patch addresses that issue.
-rw-r--r--www-client/seamonkey/files/seamonkey-2.42.2.0-fix-chatzillaless-locale-building.patch12
-rw-r--r--www-client/seamonkey/seamonkey-2.42.2.0_p0.ebuild21
2 files changed, 32 insertions, 1 deletions
diff --git a/www-client/seamonkey/files/seamonkey-2.42.2.0-fix-chatzillaless-locale-building.patch b/www-client/seamonkey/files/seamonkey-2.42.2.0-fix-chatzillaless-locale-building.patch
new file mode 100644
index 00000000..e73d0e62
--- /dev/null
+++ b/www-client/seamonkey/files/seamonkey-2.42.2.0-fix-chatzillaless-locale-building.patch
@@ -0,0 +1,12 @@
+--- a/suite/locales/Makefile.in 2016-06-30 10:08:29.000000000 -0400
++++ b/suite/locales/Makefile.in 2016-07-12 12:00:22.491851899 -0400
+@@ -123,7 +123,9 @@
+ @$(MAKE) -C $(DEPTH)/toolkit/locales libs-$*
+ @$(MAKE) -C $(DEPTH)/services/sync/locales AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C ../../editor/ui/locales AB_CD=$* XPI_NAME=locale-$*
++ifneq ($(MOZ_EXTENSIONS),$(subst irc,,$(MOZ_EXTENSIONS)))
+ @$(MAKE) -C $(DEPTH)/extensions/irc/locales libs-$*
++endif
+ @$(MAKE) -C $(DEPTH)/extensions/spellcheck/locales AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C $(DEPTH)/intl/locales AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C $(DEPTH)/devtools/client/locales AB_CD=$* XPI_NAME=locale-$*
diff --git a/www-client/seamonkey/seamonkey-2.42.2.0_p0.ebuild b/www-client/seamonkey/seamonkey-2.42.2.0_p0.ebuild
index 79286105..98d052c9 100644
--- a/www-client/seamonkey/seamonkey-2.42.2.0_p0.ebuild
+++ b/www-client/seamonkey/seamonkey-2.42.2.0_p0.ebuild
@@ -134,7 +134,8 @@ src_unpack() {
src_prepare() {
# Apply our patches
- eapply "${WORKDIR}"/seamonkey
+ eapply "${WORKDIR}"/seamonkey \
+ "${FILESDIR}"/${MY_MOZ_P}-fix-chatzillaless-locale-building.patch
# browser patches go here
pushd "${S}"/mozilla &>/dev/null || die
@@ -346,6 +347,24 @@ src_install() {
rm -rf "${ED}"/usr/include "${ED}${MOZILLA_FIVE_HOME}"/{idl,include,lib,sdk}
fi
+ if use chatzilla ; then
+ local emid='{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}'
+
+ # remove the en_US-only xpi file so a version with all requested locales can be installed
+ if [[ -e "${ED}"${MOZILLA_FIVE_HOME}/distribution/extensions/${emid}.xpi ]]; then
+ rm -f "${ED}"${MOZILLA_FIVE_HOME}/distribution/extensions/${emid}.xpi || die
+ fi
+
+ # merge the extra locales into the main extension
+ mozlinguas_xpistage_langpacks "${BUILD_OBJ_DIR}"/dist/xpi-stage/chatzilla
+
+ # install the merged extension
+ mkdir -p "${T}/${emid}" || die
+ cp -RLp -t "${T}/${emid}" "${BUILD_OBJ_DIR}"/dist/xpi-stage/chatzilla/* || die
+ insinto ${MOZILLA_FIVE_HOME}/distribution/extensions
+ doins -r "${T}/${emid}"
+ fi
+
# Handle plugins dir through nsplugins.eclass
share_plugins_dir