aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-09-28 13:47:32 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-09-28 13:48:39 -0400
commitb1908a81624ef431c4b80e7b311c56f581b90735 (patch)
tree56a1792fc9bed98daff4c999f9f6ad9895555ee4
parentmozconfig-v6.56.eclass: bump libpng dep to 1.6.31 (diff)
downloadmozilla-b1908a81.tar.gz
mozilla-b1908a81.tar.bz2
mozilla-b1908a81.zip
Revert "www-client/firefox: add eme-free use flag to buildtime-disable all DRM plugin loading"
This reverts commit 91705546be499697c47b56a28895a519b7c31444 and commit a17df3d6c9060249605bcc9c14b4fac28efdede3. Upstream removed the ability to compile-time-disable EME, so the only thing left is the pref() method which needs no use flag.
-rw-r--r--www-client/firefox/firefox-52.4.0.ebuild8
-rw-r--r--www-client/firefox/firefox-56.0.ebuild8
-rw-r--r--www-client/firefox/metadata.xml1
3 files changed, 6 insertions, 11 deletions
diff --git a/www-client/firefox/firefox-52.4.0.ebuild b/www-client/firefox/firefox-52.4.0.ebuild
index 4c967d63..ab4e45da 100644
--- a/www-client/firefox/firefox-52.4.0.ebuild
+++ b/www-client/firefox/firefox-52.4.0.ebuild
@@ -39,7 +39,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-lin
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist eme-free +gmp-autoupdate hardened hwaccel jack pgo rust selinux test"
+IUSE="bindist +gmp-autoupdate hardened hwaccel jack pgo rust selinux test"
RESTRICT="!bindist? ( bindist )"
PATCH_URIS=( https://dev.gentoo.org/~{anarchy,axs,polynomial-c}/mozilla/patchsets/${PATCH}.tar.xz )
@@ -204,8 +204,6 @@ src_configure() {
# enable JACK, bug 600002
mozconfig_use_enable jack
- use eme-free && mozconfig_annotate '+eme-free' --disable-eme
-
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
@@ -300,7 +298,7 @@ src_install() {
|| die
local plugin
- use gmp-autoupdate || use eme-free || for plugin in "${GMP_PLUGIN_LIST[@]}" ; do
+ use gmp-autoupdate || for plugin in "${GMP_PLUGIN_LIST[@]}" ; do
echo "pref(\"media.${plugin}.autoupdate\", false);" >> \
"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
|| die
@@ -388,7 +386,7 @@ pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update
- if ! use gmp-autoupdate && ! use eme-free ; then
+ if ! use gmp-autoupdate ; then
elog "USE='-gmp-autoupdate' has disabled the following plugins from updating or"
elog "installing into new profiles:"
local plugin
diff --git a/www-client/firefox/firefox-56.0.ebuild b/www-client/firefox/firefox-56.0.ebuild
index b970878d..144ad8f8 100644
--- a/www-client/firefox/firefox-56.0.ebuild
+++ b/www-client/firefox/firefox-56.0.ebuild
@@ -38,7 +38,7 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist eme-free +gmp-autoupdate hardened hwaccel jack nsplugin pgo selinux test"
+IUSE="bindist +gmp-autoupdate hardened hwaccel jack nsplugin pgo selinux test"
RESTRICT="!bindist? ( bindist )"
PATCH_URIS=( https://dev.gentoo.org/~{anarchy,axs,polynomial-c}/mozilla/patchsets/${PATCH}.tar.xz )
@@ -195,8 +195,6 @@ src_configure() {
# enable JACK, bug 600002
mozconfig_use_enable jack
- use eme-free && mozconfig_annotate '+eme-free' --disable-eme
-
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
@@ -294,7 +292,7 @@ src_install() {
fi
local plugin
- use gmp-autoupdate || use eme-free || for plugin in "${GMP_PLUGIN_LIST[@]}" ; do
+ use gmp-autoupdate || for plugin in "${GMP_PLUGIN_LIST[@]}" ; do
echo "pref(\"media.${plugin}.autoupdate\", false);" >> \
"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
|| die
@@ -382,7 +380,7 @@ pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update
- if ! use gmp-autoupdate && ! use eme-free ; then
+ if ! use gmp-autoupdate ; then
elog "USE='-gmp-autoupdate' has disabled the following plugins from updating or"
elog "installing into new profiles:"
local plugin
diff --git a/www-client/firefox/metadata.xml b/www-client/firefox/metadata.xml
index a338b442..56f49272 100644
--- a/www-client/firefox/metadata.xml
+++ b/www-client/firefox/metadata.xml
@@ -10,7 +10,6 @@
are not binary-redistributable according to upstream.</flag>
<flag name="custom-optimization">Build with user-specified compiler optimizations
(-Os, -O0, -O1, -O2, -O3) from CFLAGS (unsupported)</flag>
- <flag name="eme-free">Disable EME (DRM plugin) cabability at build time</flag>
<flag name="gtk2">Use the cairo-gtk2 rendering engine</flag>
<flag name="gmp-autoupdate">Allow Gecko Media Plugins (binary blobs) to be automatically
downloaded and kept up-to-date in user profiles</flag>