aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2015-06-12 18:04:53 -0500
committerJory A. Pratt <anarchy@gentoo.org>2015-06-12 18:04:53 -0500
commite1f6f4172827ba444b8b3d1ebf34ff1fc8d23194 (patch)
treeb08bc23a4b6226e476f23fceee10072cd1f7cd46
parentUpdate firefox-38.0.5 misc bug fixes (diff)
downloadmozilla-e1f6f4172827ba444b8b3d1ebf34ff1fc8d23194.tar.gz
mozilla-e1f6f4172827ba444b8b3d1ebf34ff1fc8d23194.tar.bz2
mozilla-e1f6f4172827ba444b8b3d1ebf34ff1fc8d23194.zip
migrate gtk3 change to mozconfig-v5.38 eclass
-rw-r--r--eclass/mozconfig-v5.38.eclass8
-rw-r--r--www-client/firefox/firefox-38.0.5.ebuild2
2 files changed, 6 insertions, 4 deletions
diff --git a/eclass/mozconfig-v5.38.eclass b/eclass/mozconfig-v5.38.eclass
index ad1b1973..6acd44e9 100644
--- a/eclass/mozconfig-v5.38.eclass
+++ b/eclass/mozconfig-v5.38.eclass
@@ -45,7 +45,7 @@ esac
# Set the variable to any value if the use flag should exist but not be default-enabled.
# use-flags common among all mozilla ebuilds
-IUSE="${IUSE} dbus debug gstreamer +jemalloc3 pulseaudio selinux startup-notification system-cairo system-icu system-jpeg system-sqlite system-libvpx"
+IUSE="${IUSE} dbus debug gstreamer gtk3 +jemalloc3 pulseaudio selinux startup-notification system-cairo system-icu system-jpeg system-sqlite system-libvpx"
# some notes on deps:
# gtk:2 minimum is technically 2.10 but gio support (enabled by default) needs 2.14
@@ -144,7 +144,11 @@ mozconfig_config() {
--enable-svg \
--with-system-bz2
- mozconfig_annotate '' --enable-default-toolkit=cairo-gtk2
+ if use gtk3 ; then
+ mozconfig_annotate 'Enable Cairo Gtk+3 support' --enable-default-toolkit=cairo-gtk3
+ else
+ mozconfig_annotate '' --enable-default-toolkit=cairo-gtk2
+ fi
if has bindist ${IUSE}; then
mozconfig_use_enable !bindist official-branding
diff --git a/www-client/firefox/firefox-38.0.5.ebuild b/www-client/firefox/firefox-38.0.5.ebuild
index 0ac1f572..8061ce3d 100644
--- a/www-client/firefox/firefox-38.0.5.ebuild
+++ b/www-client/firefox/firefox-38.0.5.ebuild
@@ -232,8 +232,6 @@ src_configure() {
fi
fi
- use gtk3 && mozconfig_annotate 'Enable Cairo Gtk+3 support' --enable-default-toolkit=cairo-gtk3
-
use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
# Setup api key for location services