aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2016-06-05 16:41:07 -0500
committerJory A. Pratt <anarchy@gentoo.org>2016-06-05 16:41:07 -0500
commitbfeb3fb79880869b73df4c4a8b3d641beae84cec (patch)
tree09a29e0871e931c0ef9fb92c0da106134e9c7c8c /dev-libs
parentgenerate_langpacks.sh: use pushd/popd instead of cd (diff)
downloadmozilla-bfeb3fb79880869b73df4c4a8b3d641beae84cec.tar.gz
mozilla-bfeb3fb79880869b73df4c4a8b3d641beae84cec.tar.bz2
mozilla-bfeb3fb79880869b73df4c4a8b3d641beae84cec.zip
Update jemalloc-4.2.0, remove force-gtk2 useflag and use ggtk2 instead
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jemalloc/Manifest1
-rw-r--r--dev-libs/jemalloc/jemalloc-4.2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/Manifest b/dev-libs/jemalloc/Manifest
index e9bbcdc9..5b755f27 100644
--- a/dev-libs/jemalloc/Manifest
+++ b/dev-libs/jemalloc/Manifest
@@ -1 +1,2 @@
DIST jemalloc-4.1.0.tar.bz2 412900 SHA256 fad06d714f72adb4265783bc169c6d98eeb032d57ba02d87d1dcb4a2d933ec8e SHA512 12433101936a104115d8d93991b4849daf897bd39d6c28b1235215c7abc627163a70d19259fb1f2eeb0cdd66cfe889c2e40eb77dccee6debd73b1a4313d0de73 WHIRLPOOL 0305d1cc715c565749c5e9c2de396d349c0d79513da80b461324c82f880c6a070a932cea19802ac809810fe01690dcb24047914f937ddf167a990cf7b4110f0c
+DIST jemalloc-4.2.0.tar.bz2 430964 SHA256 b216ddaeb901697fe38bd30ea02d7505a4b60e8979092009f95cfda860d46acb SHA512 a6963ad62830472c8b85d0184d24fdd07039e41d02a7bd5177618f7b9f936c658b836ea74e4d2b771f12eea8dc9892363991cf5fab7b19a42871a8cbeb2ef1c4 WHIRLPOOL 94c030bb70b2a1538af2037ce9708e761f801b2ca86101dbe80a839757af6c7ebbc7d032eadf202f84f33cc88ebca6e0263c747d746fe4a7fc0598e9d3b278ec
diff --git a/dev-libs/jemalloc/jemalloc-4.2.0.ebuild b/dev-libs/jemalloc/jemalloc-4.2.0.ebuild
new file mode 100644
index 00000000..8c320ea1
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-4.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs multilib-build
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="debug static-libs stats"
+HTML_DOCS=( doc/jemalloc.html )
+PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
+ "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
+)
+MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
+# but jemalloc doesn't implement them in its configure; need this here to
+# supress the warnings until automagic is removed from the eclass
+QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug)
+ $(use_enable stats)
+}
+
+multilib_src_install() {
+ # Copy man file which the Makefile looks for
+ cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fixup install_name, #437362
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.1.dylib \
+ "${ED}"/usr/$(get_libdir)/libjemalloc.1.dylib || die
+ fi
+ use static-libs || find "${ED}" -name '*.a' -delete
+}