summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kuther <gimpel@sonnenkinder.org>2009-03-19 01:26:28 +0100
committerThomas Kuther <gimpel@sonnenkinder.org>2009-03-19 01:26:28 +0100
commit044201dd2376e3c7041c56e439a75896fa97bd59 (patch)
tree3a767329809d7c9708cfa49b64609f7c28219d20
parentlibart_lgpl, newer python, gtk+ dep fixes, dbus dep fixes (diff)
downloadmultilib-portage-044201dd2376e3c7041c56e439a75896fa97bd59.tar.gz
multilib-portage-044201dd2376e3c7041c56e439a75896fa97bd59.tar.bz2
multilib-portage-044201dd2376e3c7041c56e439a75896fa97bd59.zip
add dbus-glib
-rw-r--r--dev-libs/dbus-glib/Manifest3
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.80.ebuild59
-rw-r--r--dev-libs/dbus-glib/files/dbus-glib-introspection.patch78
3 files changed, 140 insertions, 0 deletions
diff --git a/dev-libs/dbus-glib/Manifest b/dev-libs/dbus-glib/Manifest
new file mode 100644
index 000000000..5cb4e3a20
--- /dev/null
+++ b/dev-libs/dbus-glib/Manifest
@@ -0,0 +1,3 @@
+AUX dbus-glib-introspection.patch 2572 RMD160 38798ef61f4145d48e16be64888c3bfb14cadf35 SHA1 8a6e76045ffc94b269b496df60988ed3b0b61849 SHA256 3c24232d968a1f60f26bf364a5f5ff140c82307f8696877996c8602a48c7984d
+DIST dbus-glib-0.80.tar.gz 688789 RMD160 802dcdc4b7c7a8805b051b7bedf44022fece27d2 SHA1 927e43f2d429cff5472ab726882347ec06e53f6b SHA256 b5330b91b3131757103da2b3147e211e71214475f5d77640022ea9bb587f645b
+EBUILD dbus-glib-0.80.ebuild 1665 RMD160 c411ea7825428745c07dc252f657b887b56cf195 SHA1 219359145c242f170c066e6b7a84f2d4d15ba02f SHA256 f4312bb92475269ff5963ab1de1255c81e439d6d6d4d354b00c2a4af0cc39d79
diff --git a/dev-libs/dbus-glib/dbus-glib-0.80.ebuild b/dev-libs/dbus-glib/dbus-glib-0.80.ebuild
new file mode 100644
index 000000000..53bfd3818
--- /dev/null
+++ b/dev-libs/dbus-glib/dbus-glib-0.80.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.80.ebuild,v 1.1 2009/03/08 19:32:07 eva Exp $
+
+EAPI="2"
+
+inherit eutils bash-completion multilib-xlibs
+
+DESCRIPTION="D-Bus bindings for glib"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bash-completion debug doc test"
+
+RDEPEND=">=sys-apps/dbus-1.1.0[lib32?]
+ >=dev-libs/glib-2.10[lib32?]
+ >=dev-libs/expat-1.95.8[lib32?]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ >=dev-util/gtk-doc-1.4 )"
+
+BASH_COMPLETION_NAME="dbus"
+
+src_prepare() {
+ # description ?
+ epatch "${FILESDIR}"/${PN}-introspection.patch
+}
+
+multilib-xlibs_src_configure_internal() {
+ econf \
+ $(use_enable bash-completion) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug checks) \
+ $(use_enable debug asserts) \
+ $(use_enable test tests) \
+ $(use_with test test-socket-dir "${T}"/dbus-test-socket) \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ $(use_enable doc gtk-doc)
+}
+
+multilib-xlibs_src_install_internal() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README || die "dodoc failed."
+
+ #FIXME: We need --with-bash-completion-dir
+ if use bash-completion ; then
+ dobashcompletion "${D}"/etc/bash_completion.d/dbus-bash-completion.sh
+ rm -rf "${D}"/etc/bash_completion.d
+ fi
+}
diff --git a/dev-libs/dbus-glib/files/dbus-glib-introspection.patch b/dev-libs/dbus-glib/files/dbus-glib-introspection.patch
new file mode 100644
index 000000000..4e65bda38
--- /dev/null
+++ b/dev-libs/dbus-glib/files/dbus-glib-introspection.patch
@@ -0,0 +1,78 @@
+diff -Npru dbus-glib-0.71-orig/tools/dbus-bus-introspect.xml dbus-glib-0.71/tools/dbus-bus-introspect.xml
+--- tools/dbus-bus-introspect.xml 1969-12-31 17:00:00.000000000 -0700
++++ tools/dbus-bus-introspect.xml 2006-07-24 14:32:01.000000000 -0600
+@@ -0,0 +1,74 @@
++ <!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN"
++"http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
++<node>
++ <interface name="org.freedesktop.DBus.Introspectable">
++ <method name="Introspect">
++ <arg name="data" direction="out" type="s"/>
++ </method>
++ </interface>
++ <interface name="org.freedesktop.DBus">
++ <method name="RequestName">
++ <arg direction="in" type="s"/>
++ <arg direction="in" type="u"/>
++ <arg direction="out" type="u"/>
++ </method>
++ <method name="ReleaseName">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="u"/>
++ </method>
++ <method name="StartServiceByName">
++ <arg direction="in" type="s"/>
++ <arg direction="in" type="u"/>
++ <arg direction="out" type="u"/>
++ </method>
++ <method name="Hello">
++ <arg direction="out" type="s"/>
++ </method>
++ <method name="NameHasOwner">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="b"/>
++ </method>
++ <method name="ListNames">
++ <arg direction="out" type="as"/>
++ </method>
++ <method name="AddMatch">
++ <arg direction="in" type="s"/>
++ </method>
++ <method name="RemoveMatch">
++ <arg direction="in" type="s"/>
++ </method>
++ <method name="GetNameOwner">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="s"/>
++ </method>
++ <method name="ListQueuedOwners">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="as"/>
++ </method>
++ <method name="GetConnectionUnixUser">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="u"/>
++ </method>
++ <method name="GetConnectionUnixProcessID">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="u"/>
++ </method>
++ <method name="GetConnectionSELinuxSecurityContext">
++ <arg direction="in" type="s"/>
++ <arg direction="out" type="ay"/>
++ </method>
++ <method name="ReloadConfig">
++ </method>
++ <signal name="NameOwnerChanged">
++ <arg type="s"/>
++ <arg type="s"/>
++ <arg type="s"/>
++ </signal>
++ <signal name="NameLost">
++ <arg type="s"/>
++ </signal>
++ <signal name="NameAcquired">
++ <arg type="s"/>
++ </signal>
++ </interface>
++</node>