summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-06-02 22:13:18 +0200
committerThomas Sachau <tommy@gentoo.org>2014-06-02 22:13:18 +0200
commit8958a49a531c23b1063e2a2287a0cf9c5dffb97d (patch)
tree233e921e1264009ace0e3994ccab5564a6068437
parentUnmask overlay ebuild packages masked by wide mask in main tree (diff)
downloadmultilib-portage-8958a49a531c23b1063e2a2287a0cf9c5dffb97d.tar.gz
multilib-portage-8958a49a531c23b1063e2a2287a0cf9c5dffb97d.tar.bz2
multilib-portage-8958a49a531c23b1063e2a2287a0cf9c5dffb97d.zip
Sync portage
-rw-r--r--sys-apps/portage/Manifest2
-rw-r--r--sys-apps/portage/portage-2.2.10-r1.ebuild (renamed from sys-apps/portage/portage-2.2.6-r1.ebuild)45
2 files changed, 27 insertions, 20 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index d3c679cb1..ca1ac98b7 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,2 +1,2 @@
-EBUILD portage-2.2.6-r1.ebuild 19203 SHA256 4b55bde3431be8fc113897279020dc60e294f1050af67d7f4703cfc6a074bd26 SHA512 8b8fd51b4c9473b23eea27050274d7453a68b285dd9eae066cdbbf11572d85fd4185bc11ef31f1d6fa7e616fb2a56d870b21d210b750cba1308474c279453c85 WHIRLPOOL cb33b890bf919fd80b66f2484296b5bf0569e3e8fce365252ac5287467050f03f0da96e1fe62801560788aa5cbff6fc7425c736a87db441b6ad746a9a5a3f955
+EBUILD portage-2.2.10-r1.ebuild 19359 SHA256 a1360fe9e6259719baebbac0a8cac92da30741c65dc0e9a36f5ad9f6e2a9bb81 SHA512 e705109a9d87652d8e321565c36fb95823f7f78f662c49315d5d43d650e27346b233fb6aa3a7d2ef9f0035d17fbdc8e6136ea6a9fa344d65a23b1e5e9fda89a8 WHIRLPOOL a11aa143962f827a07d5232dda38bc3a476e108912489e274629334766a01724bba8978d29b6659175aa17485bb37b3a2fe0ffc6f89e0f146a964cee4d8a334f
MISC metadata.xml 365 SHA256 475a792c24a7db2ae5fab7fb108bf39af08c272d03d87ef942883b297de95d6a SHA512 45a78cd446f546ca81c6d6623e0f7215e13ed81d58d6dfcf7a2614b2ad8250a7af4c9ed8b3d1c301a103f3f17b2f5d8eb16caa82267b7565798fb00383957fb6 WHIRLPOOL 1f744a508a6d6d9225087850a85e47b8effadeff6eb0600daca677f761f22c8ddcc08a972bf4b4c2d6545518710365b560f54dd43d283f19eebdb3b2a0972630
diff --git a/sys-apps/portage/portage-2.2.6-r1.ebuild b/sys-apps/portage/portage-2.2.10-r1.ebuild
index f76f7073c..81e157e9a 100644
--- a/sys-apps/portage/portage-2.2.6-r1.ebuild
+++ b/sys-apps/portage/portage-2.2.10-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.5.ebuild,v 1.1 2013/09/15 11:18:49 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.10.ebuild,v 1.2 2014/04/06 17:00:03 mgorny Exp $
# Require EAPI 2 since we now require at least python-2.6 (for python 3
# syntax support) which also requires EAPI 2.
EAPI=2
PYTHON_COMPAT=(
- pypy2_0
+ pypy pypy2_0
python3_2 python3_3 python3_4
python2_6 python2_7
)
@@ -14,13 +14,13 @@ inherit eutils git-2 multilib
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/portage.git"
EGIT_BRANCH="multilib"
-EGIT_COMMIT="5e951e83a79c1e7e6ae64d60f768b4b46e4c6f9e"
+EGIT_COMMIT="aa18688b2ff79a1d2c6b2036a3beb79781363051"
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
SLOT="0"
-IUSE="build doc epydoc +ipc linguas_ru pypy2_0 python2 python3 selinux xattr"
+IUSE="build doc epydoc +ipc linguas_ru pypy python2 python3 selinux xattr"
for _pyimpl in ${PYTHON_COMPAT[@]} ; do
IUSE+=" python_targets_${_pyimpl}"
@@ -30,16 +30,17 @@ unset _pyimpl
# Import of the io module in python-2.6 raises ImportError for the
# thread module if threading is disabled.
python_dep_ssl="python3? ( =dev-lang/python-3*[ssl] )
- !pypy2_0? ( !python2? ( !python3? (
+ !pypy? ( !python2? ( !python3? (
|| ( >=dev-lang/python-2.7[ssl] dev-lang/python:2.6[threads,ssl] )
) ) )
- pypy2_0? ( !python2? ( !python3? ( virtual/pypy:2.0[bzip2] ) ) )
+ pypy? ( !python2? ( !python3? ( virtual/pypy:0[bzip2] ) ) )
python2? ( !python3? ( || ( dev-lang/python:2.7[ssl] dev-lang/python:2.6[ssl,threads] ) ) )"
python_dep="${python_dep_ssl//\[ssl\]}"
python_dep="${python_dep//,ssl}"
python_dep="${python_dep//ssl,}"
python_dep="${python_dep}
+ python_targets_pypy? ( virtual/pypy:0 )
python_targets_pypy2_0? ( virtual/pypy:2.0 )
python_targets_python2_6? ( dev-lang/python:2.6 )
python_targets_python2_7? ( dev-lang/python:2.7 )
@@ -73,8 +74,11 @@ RDEPEND="${python_dep}
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
>=app-misc/pax-utils-0.1.17
- xattr? ( kernel_linux? ( || ( >=dev-lang/python-3.3_pre20110902 dev-python/pyxattr ) ) )
selinux? ( || ( >=sys-libs/libselinux-2.0.94[python] <sys-libs/libselinux-2.0.94 ) )
+ xattr? ( kernel_linux? (
+ $(for python_impl in python{2_6,2_7,3_2} pypy pypy2_0; do
+ echo "python_targets_${python_impl}? ( dev-python/pyxattr[python_targets_${python_impl}] )"
+ done) ) )
!<app-shells/bash-3.2_p17
!<app-admin/logrotate-3.8.0
>=sys-apps/abi-wrapper-1.0-r6"
@@ -109,6 +113,9 @@ get_python_interpreter() {
python*)
python=${impl/_/.}
;;
+ pypy)
+ python=${impl}
+ ;;
pypy*)
python=${impl/_/.}
python=${python/pypy/pypy-c}
@@ -153,15 +160,15 @@ pkg_setup() {
ewarn "Both python2 and python3 USE flags are enabled, but only one"
ewarn "can be in the shebangs. Using python3."
fi
- if use pypy2_0 && use python3 ; then
- ewarn "Both pypy2_0 and python3 USE flags are enabled, but only one"
+ if use pypy && use python3 ; then
+ ewarn "Both pypy and python3 USE flags are enabled, but only one"
ewarn "can be in the shebangs. Using python3."
fi
- if use pypy2_0 && use python2 ; then
- ewarn "Both pypy2_0 and python2 USE flags are enabled, but only one"
+ if use pypy && use python2 ; then
+ ewarn "Both pypy and python2 USE flags are enabled, but only one"
ewarn "can be in the shebangs. Using python2"
fi
- if ! use pypy2_0 && ! use python2 && ! use python3 && \
+ if ! use pypy && ! use python2 && ! use python3 && \
! compatible_python_is_selected ; then
ewarn "Attempting to select a compatible default python interpreter"
local x success=0
@@ -190,8 +197,8 @@ pkg_setup() {
EPYTHON=python3
elif use python2; then
EPYTHON=python2
- elif use pypy2_0; then
- EPYTHON=pypy-c2.0
+ elif use pypy; then
+ EPYTHON=pypy
fi
}
@@ -205,7 +212,7 @@ src_prepare() {
epatch "${WORKDIR}/${PN}-${PATCHVER}.patch"
fi
einfo "Setting portage.VERSION to ${PVR} ..."
- sed -e "s/^VERSION=.*/VERSION=\"${PVR}\"/" -i pym/portage/__init__.py || \
+ sed -e "s/^VERSION = .*/VERSION = \"${PVR}\"/" -i pym/portage/__init__.py || \
die "Failed to patch portage.VERSION"
sed -e "1s/VERSION/${PVR}/" -i doc/fragment/version || \
die "Failed to patch VERSION in doc/fragment/version"
@@ -230,8 +237,8 @@ src_prepare() {
set_shebang=python3
elif use python2; then
set_shebang=python2
- elif use pypy2_0; then
- set_shebang=pypy-c2.0
+ elif use pypy; then
+ set_shebang=pypy
fi
if [[ -n ${set_shebang} ]] ; then
einfo "Converting shebangs for ${set_shebang}..."
@@ -273,7 +280,7 @@ src_prepare() {
sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
-e "s|^\(location = \)\(/usr/portage\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.freens.org/gentoo-portage-prefix|" \
+ -e "s|^\(sync-uri = \).*|\\1rsync://prefix.gentooexperimental.org/gentoo-portage-prefix|" \
-i cnf/repos.conf || die "sed failed"
einfo "Adding FEATURES=force-prefix to make.globals ..."