summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven J Newbury <steve@snewbury.org.uk>2009-04-03 03:36:27 +0100
committerSteven J Newbury <steve@snewbury.org.uk>2009-04-03 03:36:27 +0100
commitb9d6bb76936fbe10996ecd7c80dfe0ec8941aafa (patch)
tree5b4effab088dd67b26aa5b5596a1a9b536d3c4e7
parentAdd dev-db/mysql and virtual/mysql (diff)
downloadmultilib-portage-b9d6bb76936fbe10996ecd7c80dfe0ec8941aafa.tar.gz
multilib-portage-b9d6bb76936fbe10996ecd7c80dfe0ec8941aafa.tar.bz2
multilib-portage-b9d6bb76936fbe10996ecd7c80dfe0ec8941aafa.zip
Add x11-libs/libXfont, x11-libs/libfontenc and x11-libs/xtrans.
-rw-r--r--x11-libs/libXfont/Manifest3
-rw-r--r--x11-libs/libXfont/libXfont-1.4.0.ebuild37
-rw-r--r--x11-libs/libXfont/libXfont-9999.ebuild32
-rw-r--r--x11-libs/libfontenc/Manifest3
-rw-r--r--x11-libs/libfontenc/libfontenc-1.0.4.ebuild18
-rw-r--r--x11-libs/libfontenc/libfontenc-9999.ebuild14
-rw-r--r--x11-libs/xtrans/Manifest6
-rw-r--r--x11-libs/xtrans/metadata.xml5
-rw-r--r--x11-libs/xtrans/xtrans-1.0.4.ebuild15
-rw-r--r--x11-libs/xtrans/xtrans-1.2.3.ebuild15
-rw-r--r--x11-libs/xtrans/xtrans-9999.ebuild15
11 files changed, 163 insertions, 0 deletions
diff --git a/x11-libs/libXfont/Manifest b/x11-libs/libXfont/Manifest
new file mode 100644
index 000000000..5e22d8240
--- /dev/null
+++ b/x11-libs/libXfont/Manifest
@@ -0,0 +1,3 @@
+DIST libXfont-1.4.0.tar.bz2 410560 RMD160 999e6bbbbfaa2ad238abd9b7f1d93adf95143614 SHA1 f47a2f41273cdbe5198ac700df70686fab72cd35 SHA256 eafff0157f2c7172214449d4b6b0c72328cad7026ecace226189b511791c5f75
+EBUILD libXfont-1.4.0.ebuild 963 RMD160 df9ef113d376c19293f8e3650cf4348a9e2f5d21 SHA1 8450119c05612017cc5055d0eaebc8e2ef7b1c8f SHA256 1f50b326bc461cf9116cd9c7a26d8715d698dcd401383bac643a51952341406f
+EBUILD libXfont-9999.ebuild 745 RMD160 a6137df989e164135673965308a291f96b0357b0 SHA1 7269bdb36b9b95b5402ee4308a9a070af5dc3e99 SHA256 07355db9bbb91a153c728baf697717852d77a089d85e72ce92b8941d471c027e
diff --git a/x11-libs/libXfont/libXfont-1.4.0.ebuild b/x11-libs/libXfont/libXfont-1.4.0.ebuild
new file mode 100644
index 000000000..b5921baea
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.3.4.ebuild,v 1.1 2009/01/13 02:40:07 dberkholz Exp $
+
+EAPI=1
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic multilib-native
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans[lib32?]
+ x11-libs/libfontenc[lib32?]
+ x11-proto/xproto
+ x11-proto/fontsproto
+ >=media-libs/freetype-2[lib32?]"
+DEPEND="${RDEPEND}
+ x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-bzip2
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}
diff --git a/x11-libs/libXfont/libXfont-9999.ebuild b/x11-libs/libXfont/libXfont-9999.ebuild
new file mode 100644
index 000000000..11b4738f0
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=1
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans[lib32?]
+ x11-libs/libfontenc[lib32?]
+ x11-proto/xproto
+ x11-proto/fontsproto
+ >=media-libs/freetype-2[lib32?]"
+DEPEND="${RDEPEND}
+ x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}
diff --git a/x11-libs/libfontenc/Manifest b/x11-libs/libfontenc/Manifest
new file mode 100644
index 000000000..1c86c30fa
--- /dev/null
+++ b/x11-libs/libfontenc/Manifest
@@ -0,0 +1,3 @@
+DIST libfontenc-1.0.4.tar.bz2 224063 RMD160 7a20977bb2cf382a22873053be98bcc9f0e76438 SHA1 69876a14b18c3c7c829cd79880c69db7b0732d9b SHA256 b993aa3d17e845a12a49160b5d96993059ce919c7ba902005b910b867b6258c8
+EBUILD libfontenc-1.0.4.ebuild 569 RMD160 c81e40bbfee6497cb9546340f7f3113e5d543b22 SHA1 2e8f08e766331022cfe8855db3a3f66c9f3b6284 SHA256 d5ab8dc21245572259b45591027944979480e9a2e3feb507960860f44872d355
+EBUILD libfontenc-9999.ebuild 390 RMD160 87d0d24c9cc21929db7fb527b0b05c05036ae0f3 SHA1 3882463c4c0052c8f13fca59d25a44e046b2e988 SHA256 7df239a7f675591ec4adabd80d374387a79a1b997db588a17682153c6b31192a
diff --git a/x11-libs/libfontenc/libfontenc-1.0.4.ebuild b/x11-libs/libfontenc/libfontenc-1.0.4.ebuild
new file mode 100644
index 000000000..768e8ceaf
--- /dev/null
+++ b/x11-libs/libfontenc/libfontenc-1.0.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfontenc/libfontenc-1.0.4.ebuild,v 1.11 2007/08/07 13:17:49 gustavoz Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular multilib-native
+
+DESCRIPTION="X.Org fontenc library"
+
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="--with-encodingsdir=/usr/share/fonts/encodings"
diff --git a/x11-libs/libfontenc/libfontenc-9999.ebuild b/x11-libs/libfontenc/libfontenc-9999.ebuild
new file mode 100644
index 000000000..1e2408781
--- /dev/null
+++ b/x11-libs/libfontenc/libfontenc-9999.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit x-modular multilib-native
+
+DESCRIPTION="X.Org fontenc library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="--with-encodingsdir=/usr/share/fonts/encodings"
diff --git a/x11-libs/xtrans/Manifest b/x11-libs/xtrans/Manifest
new file mode 100644
index 000000000..c9f731dc4
--- /dev/null
+++ b/x11-libs/xtrans/Manifest
@@ -0,0 +1,6 @@
+DIST xtrans-1.0.4.tar.bz2 103761 RMD160 4cccff870a9297873ae99a6a8c49bb4d545607d9 SHA1 9e6dd0970b72253f9558be43abd30bb8a802aa66 SHA256 765219fa822edeffb0650e93458e4ebf63c23176e58fce06806fb251fbfe7d8c
+DIST xtrans-1.2.3.tar.bz2 104280 RMD160 aafebaadc7c253bc8e0e424ac6879941ca1977b5 SHA1 ae6dbeddfbd1a2fca8b783dbcea20fd53b425ffa SHA256 a67a8b09d9530021e2bd4b93136f385e72a8d8e4f2c26a99aeb169bee88facf0
+EBUILD xtrans-1.0.4.ebuild 478 RMD160 4b6b817acdf4e5e3c23d5ef4fe8aeba7617f4c23 SHA1 c99ef7e23169cc0699a6a420e761e80c133a8204 SHA256 26f7ceac2a0cb73beee8b569e66a3abe82f3fd4fd476ab664ea2f4ed43f3b489
+EBUILD xtrans-1.2.3.ebuild 486 RMD160 4124e0e27716907fc9bca30e97137edfeb15aa47 SHA1 59d9f060cf94067e58a1e7dae06f273e34204899 SHA256 77bda13fa3d3caf707aa73d7c7d90ca61d62a99445fef787724a5689f0596be6
+EBUILD xtrans-9999.ebuild 426 RMD160 b1bdc29c204014a3a496528b5f92269264063d15 SHA1 b4df5a8509ab1639dc582712c4dd3a5539d16169 SHA256 3a56a731bfbe027baa455e5d860066de6de05fa9603647532f72ed8120a67019
+MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
diff --git a/x11-libs/xtrans/metadata.xml b/x11-libs/xtrans/metadata.xml
new file mode 100644
index 000000000..01c4c004e
--- /dev/null
+++ b/x11-libs/xtrans/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-libs/xtrans/xtrans-1.0.4.ebuild b/x11-libs/xtrans/xtrans-1.0.4.ebuild
new file mode 100644
index 000000000..70f441059
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.0.4.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xtrans/xtrans-1.0.4.ebuild,v 1.6 2007/12/16 17:55:37 corsair Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib-native
+
+DESCRIPTION="X.Org xtrans library"
+
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/x11-libs/xtrans/xtrans-1.2.3.ebuild b/x11-libs/xtrans/xtrans-1.2.3.ebuild
new file mode 100644
index 000000000..6dcc8a087
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.2.3.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xtrans/xtrans-1.2.3.ebuild,v 1.1 2009/01/13 02:31:43 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib-native
+
+DESCRIPTION="X.Org xtrans library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/x11-libs/xtrans/xtrans-9999.ebuild b/x11-libs/xtrans/xtrans-9999.ebuild
new file mode 100644
index 000000000..e06b26c31
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-9999.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit x-modular multilib-native
+
+DESCRIPTION="X.Org xtrans library"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/lib/lib${PN}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=x11-misc/util-macros-1.2"