summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2015-06-20 16:58:00 +0200
committerThomas Sachau <tommy@gentoo.org>2015-06-20 16:58:00 +0200
commitadce70b663efc8b0f367978fa85106f1701bedae (patch)
tree55f05ccd55ed17faae712038f8fea2b7f4386279 /app-emulation
parentAdd missing file (diff)
downloadmultilib-portage-adce70b663efc8b0f367978fa85106f1701bedae.tar.gz
multilib-portage-adce70b663efc8b0f367978fa85106f1701bedae.tar.bz2
multilib-portage-adce70b663efc8b0f367978fa85106f1701bedae.zip
Follow wine: version bump
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/files/wine-1.7.45-libunwind-osx-only.patch64
-rw-r--r--app-emulation/wine/wine-1.7.45.ebuild (renamed from app-emulation/wine/wine-1.7.44.ebuild)12
2 files changed, 67 insertions, 9 deletions
diff --git a/app-emulation/wine/files/wine-1.7.45-libunwind-osx-only.patch b/app-emulation/wine/files/wine-1.7.45-libunwind-osx-only.patch
new file mode 100644
index 000000000..e7a790558
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.7.45-libunwind-osx-only.patch
@@ -0,0 +1,64 @@
+From 36a9f9dd05c3b9df77c44c91663e9bd6cae1c848 Mon Sep 17 00:00:00 2001
+From: Ken Thomases <ken@codeweavers.com>
+Date: Mon, 15 Jun 2015 20:42:33 -0500
+Subject: [PATCH 1/1] configure: Only check for libunwind.h on OS X.
+
+---
+ configure | 13 ++++++++++++-
+ configure.ac | 2 +-
+ 2 files changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index a104097..c0951db 100755
+--- a/configure
++++ b/configure
+@@ -6626,7 +6626,6 @@ for ac_header in \
+ lber.h \
+ ldap.h \
+ libproc.h \
+- libunwind.h \
+ link.h \
+ linux/cdrom.h \
+ linux/compiler.h \
+@@ -7849,6 +7848,18 @@ uninstall::
+ ;;
+
+ darwin*|macosx*)
++ for ac_header in libunwind.h
++do :
++ ac_fn_c_check_header_mongrel "$LINENO" "libunwind.h" "ac_cv_header_libunwind_h" "$ac_includes_default"
++if test "x$ac_cv_header_libunwind_h" = xyes; then :
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_LIBUNWIND_H 1
++_ACEOF
++
++fi
++
++done
++
+ LIBEXT="dylib"
+ DLLFLAGS="$DLLFLAGS -fPIC"
+ LIBWINE_LDFLAGS="-multiply_defined suppress"
+diff --git a/configure.ac b/configure.ac
+index df28b27..f9df3f0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -424,7 +424,6 @@ AC_CHECK_HEADERS(\
+ lber.h \
+ ldap.h \
+ libproc.h \
+- libunwind.h \
+ link.h \
+ linux/cdrom.h \
+ linux/compiler.h \
+@@ -751,6 +750,7 @@ uninstall::
+ ;;
+
+ darwin*|macosx*)
++ AC_CHECK_HEADERS(libunwind.h)
+ LIBEXT="dylib"
+ DLLFLAGS="$DLLFLAGS -fPIC"
+ LIBWINE_LDFLAGS="-multiply_defined suppress"
+--
+1.9.1
+
diff --git a/app-emulation/wine/wine-1.7.44.ebuild b/app-emulation/wine/wine-1.7.45.ebuild
index ccb52fddc..b7e828fa0 100644
--- a/app-emulation/wine/wine-1.7.44.ebuild
+++ b/app-emulation/wine/wine-1.7.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.43.ebuild,v 1.1 2015/05/18 04:59:26 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.45.ebuild,v 1.1 2015/06/18 06:06:00 np-hardass Exp $
EAPI="5"
@@ -11,7 +11,7 @@ PLOCALE_BACKUP="en"
inherit autotools-utils eutils fdo-mime flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://source.winehq.org/git/wine.git http://source.winehq.org/git/wine.git"
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
EGIT_BRANCH="master"
inherit git-r3
SRC_URI=""
@@ -282,13 +282,6 @@ usr/share/applications/wine-winecfg.desktop"
wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
- # bug #549768
- if [[ $(gcc-major-version) = 5 ]]; then
- eerror "You need gcc-4.x to build wine; see https://bugs.gentoo.org/549768"
- eerror
- return 1
- fi
-
if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then
eerror "You need gcc-4.4+ to build 64-bit wine"
eerror
@@ -337,6 +330,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.7.12-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
+ "${FILESDIR}"/${PN}-1.7.45-libunwind-osx-only.patch # only applies to this version
)
if use gstreamer; then
# See http://bugs.winehq.org/show_bug.cgi?id=30557