aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-02-01 13:54:26 -0600
committerJory Pratt <anarchy@gentoo.org>2021-02-01 13:54:26 -0600
commit013c996a9408c6c74ea5b0aa5cdf95f9ec20d695 (patch)
treeae69e69f93b0a4a5d529dfe585518173157972ed
parentsys-apps/policycoreutils: sync with ::gentoo (diff)
downloadmusl-013c996a.tar.gz
musl-013c996a.tar.bz2
musl-013c996a.zip
media-libs/mesa: sync with current stable in ::gentoo
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/mesa-20.2.6.ebuild (renamed from media-libs/mesa/mesa-20.2.4.ebuild)18
2 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index 7fdc752e..e691156f 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -1,2 +1,2 @@
DIST mesa-20.1.10.tar.xz 12918420 BLAKE2B 408f4bc6eb0dc11199cd161d6914b77cb57313bca94f26794cbfd05332922c45dc216a64e33df9fad64cd41e1ad8b2de6c2e5f99cad234870f7a5b970a62dcbd SHA512 0d4016abfcc733c853d7b6c3c997ddc554a44088c0a4d9a7edb51ab5ad7d9e1234728b61ffcb9c82a6c5fee1429091a1c31cbeabcb1b50411337b99ee550d28a
-DIST mesa-20.2.4.tar.xz 13869928 BLAKE2B 078dc88be08d3b41d5144c4d72b0044512dc77c7afcbc6366dc7b9d435886afc65009277b215f6e2898cef98a7c52fb232d8b36bd6e6d1114326302d5acc9216 SHA512 e60decb867a3ca08b99e72aa62db8c5515696bf4a9e2642c1703479167a79b0828192f6dcca688263f5786cd524308a4410e47111fa7b97c091473e4ac4ee799
+DIST mesa-20.2.6.tar.xz 13886924 BLAKE2B 2bc5d680979b58a77105a8058da5dfea81afe05166a44d08cf243e5760b8c66e418fd78046a2c88243f56aa85a610d052f3aaf259938668cd0f4a184e9edca46 SHA512 347b275d88c0d14cacef570ed736cac07f2e607bc4c89a16b915ec01ac57dbbe698ddf9a0ad70f034e00318403351e3c728e74c72c653acf1fc99720887fa888
diff --git a/media-libs/mesa/mesa-20.2.4.ebuild b/media-libs/mesa/mesa-20.2.6.ebuild
index 0f0e31fb..ad233318 100644
--- a/media-libs/mesa/mesa-20.2.4.ebuild
+++ b/media-libs/mesa/mesa-20.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit llvm meson multilib-minimal python-any-r1 linux-info
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://archive.mesa3d.org/${MY_P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
fi
LICENSE="MIT"
@@ -373,7 +373,7 @@ multilib_src_configure() {
local platforms
use X && platforms+="x11"
use wayland && platforms+=",wayland"
- [[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ emesonargs+=(-Dplatforms=${platforms#,})
if use X || use egl; then
emesonargs+=(-Dglvnd=true)
@@ -381,6 +381,11 @@ multilib_src_configure() {
emesonargs+=(-Dglvnd=false)
fi
+ # Disable glx tls support on musl
+ if use elibc_musl; then
+ emesonargs+=( -Delf-tls=false )
+ fi
+
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -484,11 +489,6 @@ multilib_src_configure() {
vulkan_enable video_cards_radeonsi amd
fi
- # Disable glx tls support on musl
- if use elibc_musl; then
- emesonargs+=( -Delf-tls=false )
- fi
-
if use gallium; then
gallium_enable -- swrast
emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )