aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-05-07 22:47:07 -0500
committerJory Pratt <anarchy@gentoo.org>2020-05-07 22:47:07 -0500
commit09baa54449dcda1e6f26777015e80de19fd3cc2d (patch)
tree8d19a92e7b1e82720886c1327c835085d2aba870
parentsys-libs/ldb: add missing include of fcntl.h (diff)
downloadmusl-09baa544.tar.gz
musl-09baa544.tar.bz2
musl-09baa544.zip
sys-devel/gcc: bump up to 10.1.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--sys-devel/gcc/Manifest2
-rw-r--r--sys-devel/gcc/files/10.1.0/cpu_indicator.patch46
-rw-r--r--sys-devel/gcc/gcc-10.1.0.ebuild27
3 files changed, 75 insertions, 0 deletions
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index d4de0ae7..798807f6 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -1,2 +1,4 @@
+DIST gcc-10.1.0-patches-1.tar.bz2 13432 BLAKE2B 2f0517778eb012288ae305a91f84eb31a5f08f842c504201f1a8085afd42ed4c9b4a5b15f7553982c926735e8ea57307a1749004e679880ef47abad7d4596115 SHA512 cc513d8b68dcf484d37c51961c809fc6c470a8341f068b4029430ca4677e7b49155c3d964b3b9ab50c69835b32db98bcb9a91f14de14417e4611521059192118
+DIST gcc-10.1.0.tar.xz 74591240 BLAKE2B d64cf01beaaff7af9e7d5b1d5e6fdfb37cce5667b4455c1c9bbfd190e631f03555d63d52d31e7be5ac232256be11058f89d5bc7d0dcb01de44e90a52645ad87f SHA512 0cb2a74c793face751f42bc580960b00e2bfea785872a0a2155f1f1dbfaa248f9591b67f4322db0f096f8844aca9243bc02732bda106c3b6e43b02bb67eb3096
DIST gcc-9.3.0-patches-2.tar.bz2 13230 BLAKE2B d37859c753864be2c4b8c98847f6e51d9c2b1c091304971c31cf680d6f2194131bac3dfd625077117ca452d6f4416e72c7892d19ccc5880eac7a6bcbe5b2a286 SHA512 c5f7c9d4350879e5ca61e97897e37e4cfea56d0c961aad8df09041e6b1fededad0d7ed89387836d0779b947bdfe7696009d5c61c73630c45f09ca1f3ec3b163c
DIST gcc-9.3.0.tar.xz 70533868 BLAKE2B 21efb1432aefad5ed9b9b395e88ef2adfda3a8ea6e3e808cd151da6e66df9fed1bafdc8b8ff055d4b2272ac786d8b7ddc4293bb6b51c55c40a261a0eda0e7cb4 SHA512 4b9e3639eef6e623747a22c37a904b4750c93b6da77cf3958d5047e9b5ebddb7eebe091cc16ca0a227c0ecbd2bf3b984b221130f269a97ee4cc18f9cf6c444de
diff --git a/sys-devel/gcc/files/10.1.0/cpu_indicator.patch b/sys-devel/gcc/files/10.1.0/cpu_indicator.patch
new file mode 100644
index 00000000..6141a83f
--- /dev/null
+++ b/sys-devel/gcc/files/10.1.0/cpu_indicator.patch
@@ -0,0 +1,46 @@
+From d16a8ceb1c3c8a7ec381090b4c316ff4c55661c0 Mon Sep 17 00:00:00 2001
+From:
+Date: Thu, 7 May 2020 21:14:11 -0500
+Subject: [PATCH] convert "__cpu_indicator_init" to
+ "__cpu_indicator_init_local"
+
+---
+ gcc/config/i386/i386-expand.c | 4 ++--
+ libgcc/config/i386/cpuinfo.c | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/gcc/config/i386/i386-expand.c b/gcc/config/i386/i386-expand.c
+index 48f00c5fc..78650b202 100644
+--- a/gcc/config/i386/i386-expand.c
++++ b/gcc/config/i386/i386-expand.c
+@@ -10941,10 +10941,10 @@ ix86_expand_builtin (tree exp, rtx target, rtx subtarget,
+ {
+ case IX86_BUILTIN_CPU_INIT:
+ {
+- /* Make it call __cpu_indicator_init in libgcc. */
++ /* Make it call __cpu_indicator_init_local in libgcc. */
+ tree call_expr, fndecl, type;
+ type = build_function_type_list (integer_type_node, NULL_TREE);
+- fndecl = build_fn_decl ("__cpu_indicator_init", type);
++ fndecl = build_fn_decl ("__cpu_indicator_init_local", type);
+ call_expr = build_call_expr (fndecl, 0);
+ return expand_expr (call_expr, target, mode, EXPAND_NORMAL);
+ }
+diff --git a/libgcc/config/i386/cpuinfo.c b/libgcc/config/i386/cpuinfo.c
+index 00322c586..f42bbb8af 100644
+--- a/libgcc/config/i386/cpuinfo.c
++++ b/libgcc/config/i386/cpuinfo.c
+@@ -508,7 +508,7 @@ __cpu_indicator_init (void)
+ return 0;
+ }
+
+-#if defined SHARED && defined USE_ELF_SYMVER
+-__asm__ (".symver __cpu_indicator_init, __cpu_indicator_init@GCC_4.8.0");
+-__asm__ (".symver __cpu_model, __cpu_model@GCC_4.8.0");
++#ifndef SHARED
++int __cpu_indicator_init_local (void)
++ __attribute__ ((weak, alias ("__cpu_indicator_init")));
+ #endif
+--
+2.26.2
+
diff --git a/sys-devel/gcc/gcc-10.1.0.ebuild b/sys-devel/gcc/gcc-10.1.0.ebuild
new file mode 100644
index 00000000..2212fc42
--- /dev/null
+++ b/sys-devel/gcc/gcc-10.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="1"
+
+inherit toolchain
+
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+
+RDEPEND=""
+DEPEND=">=${CATEGORY}/binutils-2.20"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
+ eapply "${FILESDIR}"/10.1.0/cpu_indicator.patch
+ eapply "${FILESDIR}"/7.1.0/posix_memalign.patch
+ case $(tc-arch) in
+ amd64|arm64|ppc64) eapply "${FILESDIR}"/8.3.0/gcc-pure64.patch ;;
+ esac
+ fi
+
+ eapply_user
+}