aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-09-19 07:44:43 -0500
committerJory Pratt <anarchy@gentoo.org>2020-09-19 07:44:43 -0500
commit1ba1da570f5206d2d7537b8a63004c0085a9c9cb (patch)
treee4549e14ef7d2a0be0f1c205216c82004bcd38b1
parentsys-auth/nss-myhostname: Sync EAPI=7 changes (diff)
downloadmusl-1ba1da57.tar.gz
musl-1ba1da57.tar.bz2
musl-1ba1da57.zip
media-libs/mesa: Sync stable with ::gentoo
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/files/mesa-20.1.7-add-disable-tls-support.patch (renamed from media-libs/mesa/files/mesa-19.3.0-add-disable-tls-support.patch)7
-rw-r--r--media-libs/mesa/mesa-20.1.7.ebuild (renamed from media-libs/mesa/mesa-20.0.8.ebuild)14
3 files changed, 11 insertions, 12 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index 2c19fa4d..be183337 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -1,2 +1,2 @@
-DIST mesa-20.0.8.tar.xz 12360736 BLAKE2B 19e3f8a40b34b5f17ed76077c5d92f728a134b2479c43d86674ed1818ab99639a9b732041f67488251df808564f6abe5b587d756ef9c7c13dcada87cd0fc05de SHA512 d906330c412899907dd05a84034a929107fccaf3044814c4b1f30ba5690cbcf1587b5f17534c6345111f3cb7cf292afd5984a60486643ff6f534b57cec615374
+DIST mesa-20.1.7.tar.xz 12825368 BLAKE2B 2fedda518ff29bfda49af12d714dc258e48fca3492d2327ce5080d11bbaea5ad646d438f3e2d5ddabeffae83211976fb15001c650cd6ab4052ab09d97342afdc SHA512 5ff614c3f7568db7673cd2398615e5398c7f50093abdabd0730e07fe9c358310793fea3f130058110c9a2aa284c6efd207e1bdca3d1a1ba46fb18d76e34f361a
DIST mesa-20.2.0-rc4.tar.xz 13569628 BLAKE2B 54068c298a57f2c19113828e2e9b94dd15070ecc0c899f7e3dc527b27579e4f8c3c84c7b841c8d0b8313556cca41bfefd3e08b360dd0e364cbc29e0609ff6f3d SHA512 1f718bfbadbc15b7216864226adb737f3a4a7801dc60ca9294effd4be5f260fffd31c988eed9550e8a7a7430acb05ba0c7d65693c1f375eab4b95d2d029755bb
diff --git a/media-libs/mesa/files/mesa-19.3.0-add-disable-tls-support.patch b/media-libs/mesa/files/mesa-20.1.7-add-disable-tls-support.patch
index 1686d88f..b64b4291 100644
--- a/media-libs/mesa/files/mesa-19.3.0-add-disable-tls-support.patch
+++ b/media-libs/mesa/files/mesa-20.1.7-add-disable-tls-support.patch
@@ -10,14 +10,14 @@ Signed-off-by: Jory Pratt <anarchy@gentoo.org>
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 898d025..568f32c 100644
+index 4eda551..87fe071 100644
--- a/meson.build
+++ b/meson.build
-@@ -387,7 +387,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
+@@ -427,7 +427,7 @@ else
endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
--if host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+-if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+if get_option('elf-tls')
pre_args += '-DUSE_ELF_TLS'
endif
@@ -42,3 +42,4 @@ index 626baf3..d30a238 100644
--
2.24.0
+
diff --git a/media-libs/mesa/mesa-20.0.8.ebuild b/media-libs/mesa/mesa-20.1.7.ebuild
index c378ffa8..20f66299 100644
--- a/media-libs/mesa/mesa-20.0.8.ebuild
+++ b/media-libs/mesa/mesa-20.1.7.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/mesa.git"
inherit git-r3
else
- SRC_URI="https://mesa.freedesktop.org/archive/${MY_P}.tar.xz"
+ SRC_URI="https://archive.mesa3d.org/${MY_P}.tar.xz"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
fi
@@ -151,7 +151,6 @@ LLVM_DEPSTR="
|| (
sys-devel/llvm:10[${MULTILIB_USEDEP}]
sys-devel/llvm:9[${MULTILIB_USEDEP}]
- sys-devel/llvm:8[${MULTILIB_USEDEP}]
)
<sys-devel/llvm-$((LLVM_MAX_SLOT + 1)):=[${MULTILIB_USEDEP}]
"
@@ -247,7 +246,7 @@ x86? (
)"
PATCHES=(
- "${FILESDIR}"/${PN}-19.3.0-add-disable-tls-support.patch
+ "${FILESDIR}"/${PN}-20.1.7-add-disable-tls-support.patch
)
llvm_check_deps() {
@@ -338,11 +337,9 @@ pkg_setup() {
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
- # os_same_file_description requires the kcmp syscall,
- # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
- # Currently only AMDGPU utilizes this function, so only AMDGPU users would
- # get a spooky warning message if the syscall fails.
- if use gallium && use video_cards_radeonsi; then
+ if use video_cards_i965 ||
+ use video_cards_iris ||
+ use video_cards_radeonsi; then
CONFIG_CHECK="~CHECKPOINT_RESTORE"
linux-info_pkg_setup
fi
@@ -513,6 +510,7 @@ multilib_src_configure() {
-Ddri-drivers=$(driver_list "${DRI_DRIVERS[*]}")
-Dgallium-drivers=$(driver_list "${GALLIUM_DRIVERS[*]}")
-Dvulkan-drivers=$(driver_list "${VULKAN_DRIVERS[*]}")
+ $(meson_use vulkan vulkan-device-select-layer)
$(meson_use vulkan-overlay vulkan-overlay-layer)
--buildtype $(usex debug debug plain)
-Db_ndebug=$(usex debug false true)