aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-02-03 09:19:04 -0600
committerJory Pratt <anarchy@gentoo.org>2021-02-03 09:19:04 -0600
commit2fdb2f1ac295effe383e2c1131b80075c5408010 (patch)
tree28c654a1a004465573d112502ca46596d756be58
parentmedia-libs/mesa: sync with current stable in ::gentoo (diff)
downloadmusl-2fdb2f1a.tar.gz
musl-2fdb2f1a.tar.bz2
musl-2fdb2f1a.zip
media-tv/kodi: sync with ::gentoo
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--media-tv/kodi/kodi-19.0_rc1-r2.ebuild (renamed from media-tv/kodi/kodi-19.0_rc1.ebuild)31
-rw-r--r--media-tv/kodi/metadata.xml5
2 files changed, 32 insertions, 4 deletions
diff --git a/media-tv/kodi/kodi-19.0_rc1.ebuild b/media-tv/kodi/kodi-19.0_rc1-r2.ebuild
index d190d9d7..abda01f8 100644
--- a/media-tv/kodi/kodi-19.0_rc1.ebuild
+++ b/media-tv/kodi/kodi-19.0_rc1-r2.ebuild
@@ -39,7 +39,8 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl pulseaudio raspberry-pi samba systemd +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( gles opengl )
@@ -49,6 +50,7 @@ REQUIRED_USE="
udev? ( !libusb )
udisks? ( dbus )
upower? ( dbus )
+ power-control? ( dbus )
"
RESTRICT="!test? ( test )"
@@ -88,17 +90,17 @@ COMMON_DEPEND="${PYTHON_DEPS}
libusb? ( virtual/libusb:1 )
virtual/ttf-fonts
media-fonts/roboto
- media-libs/dav1d
>=media-libs/fontconfig-2.13.1
>=media-libs/freetype-2.10.1
>=media-libs/libass-0.13.4
!raspberry-pi? ( media-libs/mesa[egl] )
>=media-libs/taglib-1.11.1
system-ffmpeg? (
- >=media-video/ffmpeg-${FFMPEG_VERSION}:=[dav1d,encode,postproc]
+ >=media-video/ffmpeg-${FFMPEG_VERSION}:=[dav1d?,encode,postproc]
libressl? ( media-video/ffmpeg[libressl,-openssl] )
!libressl? ( media-video/ffmpeg[-libressl,openssl] )
)
+ !system-ffmpeg? ( dav1d? ( media-libs/dav1d ) )
mysql? ( dev-db/mysql-connector-c:= )
mariadb? ( dev-db/mariadb-connector-c:= )
>=net-misc/curl-7.68.0[http2]
@@ -147,6 +149,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
"
RDEPEND="${COMMON_DEPEND}
lirc? ( app-misc/lirc )
+ power-control? ( || ( sys-apps/systemd sys-auth/elogind ) )
udisks? ( sys-fs/udisks:2 )
upower? ( sys-power/upower )
"
@@ -230,7 +233,16 @@ src_configure() {
use X && platform+=( x11 )
local core_platform_name="${platform[@]}"
local mycmakeargs=(
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2)
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon)
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -DVERBOSE=ON
-DENABLE_LDGOLD=OFF # https://bugs.gentoo.org/show_bug.cgi?id=606124
-DENABLE_ALSA=$(usex alsa)
-DENABLE_AIRTUNES=$(usex airplay)
@@ -238,18 +250,25 @@ src_configure() {
-DENABLE_BLUETOOTH=$(usex bluetooth)
-DENABLE_BLURAY=$(usex bluray)
-DENABLE_CCACHE=OFF
+ -DENABLE_ISO9660PP=ON
-DENABLE_CEC=$(usex cec)
-DENABLE_DBUS=$(usex dbus)
-DENABLE_DVDCSS=$(usex css)
-DENABLE_INTERNAL_CROSSGUID=OFF
+ -DENABLE_INTERNAL_RapidJSON=OFF
+ -DENABLE_INTERNAL_FMT=OFF
-DENABLE_INTERNAL_FFMPEG="$(usex !system-ffmpeg)"
-DENABLE_INTERNAL_FSTRCMP=OFF
+ -DENABLE_INTERNAL_FLATBUFFERS=OFF
+ -DENABLE_INTERNAL_DAV1D=OFF
-DENABLE_INTERNAL_GTEST=OFF
-DENABLE_INTERNAL_UDFREAD=OFF
+ -DENABLE_INTERNAL_SPDLOG=OFF
-DENABLE_CAP=$(usex caps)
-DENABLE_LCMS2=$(usex lcms)
-DENABLE_LIRCCLIENT=$(usex lirc)
-DENABLE_MARIADBCLIENT=$(usex mariadb)
+ -DENABLE_MDNS=OFF # used only on Android
-DENABLE_MICROHTTPD=$(usex webserver)
-DENABLE_MYSQLCLIENT=$(usex mysql)
-DENABLE_NFS=$(usex nfs)
@@ -259,6 +278,7 @@ src_configure() {
-DENABLE_PLIST=$(usex airplay)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_SMBCLIENT=$(usex samba)
+ -DENABLE_SNDIO=OFF
-DENABLE_TESTING=$(usex test)
-DENABLE_UDEV=$(usex udev)
-DENABLE_UDFREAD=$(usex udf)
@@ -283,6 +303,11 @@ src_configure() {
mycmakeargs+=( -DFFMPEG_URL="${DISTDIR}/ffmpeg-${PN}-${FFMPEG_VERSION}-${CODENAME}-${FFMPEG_KODI_VERSION}.tar.gz" )
fi
+ if ! echo "${CFLAGS}" | grep -Fwqe '-DNDEBUG' - && ! echo "${CFLAGS}" | grep -Fwqe '-D_DEBUG' - ; then
+ CFLAGS+=' -DNDEBUG' # Kodi requires one of the 'NDEBUG' or '_DEBUG' defines
+ CXXFLAGS+=' -DNDEBUG'
+ fi
+
cmake_src_configure
}
diff --git a/media-tv/kodi/metadata.xml b/media-tv/kodi/metadata.xml
index 1fa46ecc..a30254b9 100644
--- a/media-tv/kodi/metadata.xml
+++ b/media-tv/kodi/metadata.xml
@@ -8,13 +8,16 @@
<use>
<flag name="airplay">enable AirPlay support</flag>
<flag name="bluray">Enable playback of Blu-ray filesystems</flag>
+ <flag name="caps">Use <pkg>sys-libs/libcap</pkg> to bind to privileged ports as non-root</flag>
<flag name="cec">Enable support for HDMI-CEC devices via libcec</flag>
<flag name="gbm">Use the Graphics Buffer Manager for EGL on KMS.</flag>
<flag name="gles">Enable support for GLES</flag>
- <flag name="lirc">Enable support for controlling Totem with a remote control using <pkg>app-misc/lirc</pkg></flag>
+ <flag name="lirc">Enable support for IR remote controls using <pkg>app-misc/lirc</pkg></flag>
<flag name="mariadb">Add MariaDB support</flag>
+ <flag name="dav1d">Enables AV1 decoding via <pkg>media-libs/dav1d</pkg></flag>
<flag name="nfs">Enable NFS client support</flag>
<flag name="dvd">Enable optical (CD/DVD drive) support</flag>
+ <flag name="power-control">Enable control of shutdown, reboot, suspend, and hibernate</flag>
<flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
<flag name="system-ffmpeg">Use system ffmpeg instead of the bundled one</flag>
<flag name="libusb">Use <pkg>virtual/libusb</pkg> for usb device hotplug support. This flag should only be enabled if you're running a non-Linux kernel or you don't want to use <pkg>sys-fs/udev</pkg>.</flag>