aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2022-02-08 19:14:26 -0600
committerJory Pratt <anarchy@gentoo.org>2022-02-08 19:14:26 -0600
commit431e7dfb693249a68f64dedcdf705f66b6b2c7df (patch)
tree54c7ce68cf9c7a7871688d528bbf5c71f09cec38
parentdev-libs/libgamin: treeclean (now in ::gentoo) (diff)
downloadmusl-431e7dfb693249a68f64dedcdf705f66b6b2c7df.tar.gz
musl-431e7dfb693249a68f64dedcdf705f66b6b2c7df.tar.bz2
musl-431e7dfb693249a68f64dedcdf705f66b6b2c7df.zip
media-libs/mesa: Version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/mesa-21.3.5.ebuild (renamed from media-libs/mesa/mesa-21.3.4.ebuild)20
-rw-r--r--media-libs/mesa/metadata.xml2
3 files changed, 17 insertions, 7 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index 6fdb1557..46c11706 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -1 +1 @@
-DIST mesa-21.3.4.tar.xz 16497248 BLAKE2B 3fe2543bb6286a0d84a247785dbb4b5dd6df905eab748a89854589008d9db5aae6c52e473c58cff8d03694d46d3ce2a2680fddc8c978f898dc9bcdec02ca9b6b SHA512 7aeea3dba0d39f4ac9f23c54aa0e6853d48000f50c4dd484618c28debe705cdd765ae8fafb5ddea0773976f7189849d9128be3f2282fea74394b59019cb786b9
+DIST mesa-21.3.5.tar.xz 16521664 BLAKE2B 4dcf2e40103233332724289434998149c41a86fdaef622c2fc92065d1708a0635ed5a179e5fc8e51d82efe794f4f99c7de734ed61a8804b5e94aecb071656795 SHA512 417d1787f8177567f0c547dde3e24212f7497f2fe7cdaa945fe998cd61ec0e9eb9388feb444e377c4fd8794b056af02aac28d1bbfb9527844391ba49e6893933
diff --git a/media-libs/mesa/mesa-21.3.4.ebuild b/media-libs/mesa/mesa-21.3.5.ebuild
index f9fd08f6..a44b9afd 100644
--- a/media-libs/mesa/mesa-21.3.4.ebuild
+++ b/media-libs/mesa/mesa-21.3.5.ebuild
@@ -17,7 +17,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://archive.mesa3d.org/${MY_P}.tar.xz"
- KEYWORDS="amd64 arm arm64 ~mips ~ppc ~ppc64 x86"
+ KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 x86"
fi
LICENSE="MIT"
@@ -33,15 +33,18 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic cpu_flags_x86_sse2 d3d9 debug +gallium gles1 +gles2 +llvm
+ +classic cpu_flags_x86_sse2 d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
d3d9? ( || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
+ gles1? ( egl )
+ gles2? ( egl )
osmesa? ( gallium )
vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
+ wayland? ( egl gbm )
video_cards_crocus? ( gallium )
video_cards_freedreno? ( gallium )
video_cards_intel? ( classic )
@@ -61,7 +64,7 @@ REQUIRED_USE="
video_cards_v3d? ( gallium )
video_cards_vc4? ( gallium )
video_cards_virgl? ( gallium )
- video_cards_vivante? ( gallium )
+ video_cards_vivante? ( gallium gbm )
video_cards_vmware? ( gallium )
xa? ( X )
xvmc? ( X )
@@ -387,6 +390,12 @@ multilib_src_configure() {
use wayland && platforms+=",wayland"
emesonargs+=(-Dplatforms=${platforms#,})
+ if use X || use egl; then
+ emesonargs+=(-Dglvnd=true)
+ else
+ emesonargs+=(-Dglvnd=false)
+ fi
+
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -509,9 +518,8 @@ multilib_src_configure() {
-Dglx=$(usex X dri disabled)
-Dshared-glapi=enabled
-Ddri3=enabled
- -Degl=true
- -Dgbm=true
- -Dglvnd=true
+ $(meson_feature egl)
+ $(meson_feature gbm)
$(meson_feature gles1)
$(meson_feature gles2)
$(meson_use osmesa)
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index b181eed2..2b18aba1 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -8,7 +8,9 @@
<use>
<flag name="classic">Build drivers based on the classic architecture.</flag>
<flag name="d3d9">Enable Direct 3D9 API through Nine state tracker. Can be used together with patched wine.</flag>
+ <flag name="egl">Enable EGL support.</flag>
<flag name="gallium">Build drivers based on Gallium3D, the new architecture for 3D graphics drivers.</flag>
+ <flag name="gbm">Enable the Graphics Buffer Manager for EGL on KMS.</flag>
<flag name="gles1">Enable GLESv1 support.</flag>
<flag name="gles2">Enable GLESv2 support.</flag>
<flag name="llvm">Enable LLVM backend for Gallium3D.</flag>