aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2022-01-17 18:17:53 -0600
committerJory Pratt <anarchy@gentoo.org>2022-01-17 18:17:53 -0600
commit863aea8ddc6cf3904f39f5014e323a46e8467bf6 (patch)
tree94103cdcec2f95e7099eb84794aefcffb8c1be15
parentsys-libs/gpm: Current ::gentoo stable is fine (diff)
downloadmusl-863aea8d.tar.gz
musl-863aea8d.tar.bz2
musl-863aea8d.zip
sys-libs/slang: remove eapi5 ebuild
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--sys-libs/slang/Manifest1
-rw-r--r--sys-libs/slang/files/slang-2.2.3-slsh-libs.patch11
-rw-r--r--sys-libs/slang/files/slang-2.2.4-memset.patch32
-rw-r--r--sys-libs/slang/files/slang-2.2.4-rename-posix_close.patch21
-rw-r--r--sys-libs/slang/metadata.xml8
-rw-r--r--sys-libs/slang/slang-2.3.0.ebuild71
6 files changed, 0 insertions, 144 deletions
diff --git a/sys-libs/slang/Manifest b/sys-libs/slang/Manifest
deleted file mode 100644
index 1b79ed64..00000000
--- a/sys-libs/slang/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST slang-2.3.0.tar.bz2 1532986 SHA256 f95224060f45e0d8212a5039b339afa5f1a94a1bb0298e796104e5b12e926129 SHA512 0b04d916409c59f66301877c078bcca63c8b71e5dfa6c1d804353e41949bca16e664a79381c4156068b1f878c333e618f1de165e4059b09831fa83a794613050 WHIRLPOOL 395dc36d2f571ed19d88ee1f1c3594ab50d3a955949724d46582191430aa0c23cf3f78f966b184f3220ab86f2939e4601821160455159783793df30597c53257
diff --git a/sys-libs/slang/files/slang-2.2.3-slsh-libs.patch b/sys-libs/slang/files/slang-2.2.3-slsh-libs.patch
deleted file mode 100644
index 2c999fb1..00000000
--- a/sys-libs/slang/files/slang-2.2.3-slsh-libs.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- slsh/Makefile.in
-+++ slsh/Makefile.in
-@@ -80,7 +80,7 @@
- $(OBJDIR)/slsh_exe: $(OBJDIR)/slsh.o $(OBJDIR)/readline.o
- $(CC) $(CFLAGS) $(OBJDIR)/slsh.o $(OBJDIR)/readline.o -o $(OBJDIR)/slsh_exe $(LDFLAGS) $(SRC_LIBS)
- $(OBJDIR)/slsh: $(OBJDIR)/slsh.o $(OBJDIR)/readline.o
-- $(CC) $(CFLAGS) $(OBJDIR)/slsh.o $(OBJDIR)/readline.o -o $(OBJDIR)/slsh $(LDFLAGS) $(INST_LIBS)
-+ $(CC) $(CFLAGS) $(OBJDIR)/slsh.o $(OBJDIR)/readline.o -o $(OBJDIR)/slsh $(LDFLAGS) $(SRC_LIBS)
- $(OBJDIR)/slsh.o: $(OBJDIR) slsh.c slsh.h config.h Makefile
- cd $(OBJDIR) && $(CC) -c $(CFLAGS) $(SLANG_SRCINC) $(DEFS) $(SRCDIR)/slsh.c
- $(OBJDIR)/readline.o: $(OBJDIR) readline.c slsh.h config.h Makefile
diff --git a/sys-libs/slang/files/slang-2.2.4-memset.patch b/sys-libs/slang/files/slang-2.2.4-memset.patch
deleted file mode 100644
index 0be90fdc..00000000
--- a/sys-libs/slang/files/slang-2.2.4-memset.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From e06be392e42c23dd9bd7205445f3c5232ddb9ed7 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Tue, 19 Nov 2013 15:17:52 +0300
-Subject: [PATCH] modules/png-module.c: add declaration of 'memset'
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
- * QA Notice: Package triggers severe warnings which indicate that it
- * may exhibit random runtime failures.
- * /tmp/portage/sys-libs/slang-2.2.4/work/slang-2.2.4/modules/png-module.c:122:2: warning: incompatible implicit declaration of built-in function ‘memset’ [enabled by default]
-
-Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- modules/png-module.c | 1 +
- 3 files changed, 403 insertions(+), 259 deletions(-)
-
-diff --git a/modules/png-module.c b/modules/png-module.c
-index 92ede3d..fed9392 100644
---- a/modules/png-module.c
-+++ b/modules/png-module.c
-@@ -23,6 +23,7 @@ USA.
- #include "config.h"
-
- #include <stdio.h>
-+#include <string.h> /* memset() */
- #include <errno.h>
- #include <slang.h>
-
---
-1.8.4
-
diff --git a/sys-libs/slang/files/slang-2.2.4-rename-posix_close.patch b/sys-libs/slang/files/slang-2.2.4-rename-posix_close.patch
deleted file mode 100644
index 35235edf..00000000
--- a/sys-libs/slang/files/slang-2.2.4-rename-posix_close.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur slang-2.2.4.orig/src/slposio.c slang-2.2.4/src/slposio.c
---- slang-2.2.4.orig/src/slposio.c 2011-04-10 22:37:07.000000000 -0400
-+++ slang-2.2.4/src/slposio.c 2015-07-16 13:02:06.594941984 -0400
-@@ -363,7 +363,7 @@
- return 0;
- }
-
--static int posix_close (SLFile_FD_Type *f)
-+static int posix_close_1 (SLFile_FD_Type *f)
- {
- int status = do_close (f);
-
-@@ -1001,7 +1001,7 @@
- MAKE_INTRINSIC_2("write", posix_write, V, F, B),
- MAKE_INTRINSIC_1("dup_fd", posix_dup, V, F),
- MAKE_INTRINSIC_2("dup2_fd", posix_dup2, I, F, I),
-- MAKE_INTRINSIC_1("close", posix_close, I, F),
-+ MAKE_INTRINSIC_1("close", posix_close_1, I, F),
- MAKE_INTRINSIC_1("_close", posix_close_fd, I, I),
- #if defined(TTYNAME_R)
- MAKE_INTRINSIC_0("ttyname", posix_ttyname, V),
diff --git a/sys-libs/slang/metadata.xml b/sys-libs/slang/metadata.xml
deleted file mode 100644
index 6f2ca22d..00000000
--- a/sys-libs/slang/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
-</pkgmetadata>
diff --git a/sys-libs/slang/slang-2.3.0.ebuild b/sys-libs/slang/slang-2.3.0.ebuild
deleted file mode 100644
index a788edd0..00000000
--- a/sys-libs/slang/slang-2.3.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib-minimal
-
-DESCRIPTION="A multi-platform programmer's library designed to allow a developer to create robust software"
-HOMEPAGE="http://www.jedsoft.org/slang/"
-SRC_URI="http://www.jedsoft.org/releases/${PN}/${P}.tar.bz2
- http://www.jedsoft.org/releases/${PN}/old/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc x86"
-IUSE="cjk pcre png readline static-libs zlib"
-
-# ncurses for ncurses5-config to get terminfo directory
-RDEPEND="sys-libs/ncurses:0=
- pcre? ( >=dev-libs/libpcre-8.33-r1[${MULTILIB_USEDEP}] )
- png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
- cjk? ( >=dev-libs/oniguruma-5.9.5[${MULTILIB_USEDEP}] )
- readline? ( >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2.3-slsh-libs.patch
- epatch "${FILESDIR}"/${PN}-2.2.4-memset.patch
- epatch "${FILESDIR}"/${PN}-2.2.4-rename-posix_close.patch
-
- # avoid linking to -ltermcap race with some systems
- sed -i -e '/^TERMCAP=/s:=.*:=:' configure || die
- # we use the GNU linker also on Solaris
- sed -i -e 's/-G -fPIC/-shared -fPIC/g' \
- -e 's/-Wl,-h,/-Wl,-soname,/g' configure || die
-
- # slang does not support configuration from another dir
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myconf=slang
- use readline && myconf=gnu
-
- econf \
- --with-readline=${myconf} \
- $(use_with pcre) \
- $(use_with cjk onig) \
- $(use_with png) \
- $(use_with zlib z)
-}
-
-multilib_src_compile() {
- emake elf $(use static-libs && echo static)
-
- pushd slsh >/dev/null
- emake slsh
- popd
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install $(use static-libs && echo install-static)
-}
-
-multilib_src_install_all() {
- rm -rf "${ED}"/usr/share/doc/{slang,slsh}
- dodoc NEWS README *.txt doc/{,internal,text}/*.txt
- dohtml doc/slangdoc.html slsh/doc/html/*.html
-}