aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-02-26 06:43:56 -0500
committerAnthony G. Basile <blueness@gentoo.org>2020-02-26 06:43:56 -0500
commit8ee55df6768d90b93fb57f6172bcd457eedcc9e8 (patch)
treebc47477a48b7acc0e055646b16c81b2dec6958a0
parentdev-qt/qtwebengine: bump to 5.13.2 (diff)
downloadmusl-8ee55df6.tar.gz
musl-8ee55df6.tar.bz2
musl-8ee55df6.zip
net-libs/libtirpc: sync with tree
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-libs/libtirpc/Manifest1
-rw-r--r--net-libs/libtirpc/libtirpc-1.2.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/libtirpc/Manifest b/net-libs/libtirpc/Manifest
index 2919a0ce..3d4f7dc6 100644
--- a/net-libs/libtirpc/Manifest
+++ b/net-libs/libtirpc/Manifest
@@ -1,3 +1,4 @@
DIST libtirpc-1.0.3.tar.bz2 509831 BLAKE2B 3f908471b3e10f88329793db2c832754b9bb838d115235d7c25256da883960de8d8c94a6941fc9c2a3cc4dca9a77c32b5cb85bb347cc182e5a6255636b79b06e SHA512 1f1cf7dd6f30ddddc919e4caf6db926f1d532f78d5a93e8aaa2acde6b046be0650c4c46549da0ffd5fa7fb9e550af1a871ed6e02ededf504c6667d2e82eba2cc
DIST libtirpc-1.1.4.tar.bz2 510924 BLAKE2B 1780f9bb0543583c01b60bda681add0ec2f8718eda4ce4653883c772466178e37d0a3fb47004109f81de470129458561fac4f109f45154c64b6fb729f0212c90 SHA512 392f391f9fc1bd68d81dc44e4058831a64b32790b5c8c37338b0ab416fad2ae4d16389e632596734dba09780347918cc65c6f134e0c1afd09e81ec250785ed23
+DIST libtirpc-1.2.5.tar.bz2 513146 BLAKE2B 732e4832f3440d9fa08c45c01c56135ff1b96564c55d33e9b3f16c8361a4f02e49a35638b73110bb72da4bfb78107ccb1b4d475d1ecbdd62dcc156529a372c3e SHA512 d31cd4e22301abe1baddd7e8f45aaaf056a40799e961646691d071084fed50563b5eecdd9b78062fe378be8db7a6d4b87597e21cb81ac925e447148684a2b002
DIST libtirpc-glibc-nfs.tar.xz 8948 BLAKE2B 7316623d9f2b6928e296137fe2bf6794b208d549c2ffba9e4a35b47f7b04bf023798a09f38c02d039debf6adc466d7689cf3c8274d71a22eaff08729642c0a28 SHA512 90255bf0a27af16164e0710dd940778609925d473f4343093ff19d98cc4f23023788bf4edf0178eae1961afc0ba8b69b273de95b7d7e2afdb706701d8ba6f7ba
diff --git a/net-libs/libtirpc/libtirpc-1.2.5.ebuild b/net-libs/libtirpc/libtirpc-1.2.5.ebuild
new file mode 100644
index 00000000..56c9342d
--- /dev/null
+++ b/net-libs/libtirpc/libtirpc-1.2.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal toolchain-funcs usr-ldscript
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="https://sourceforge.net/projects/libtirpc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-glibc-nfs.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # subslot matches SONAME major
+KEYWORDS="amd64 arm arm64 ~mips ppc x86"
+IUSE="ipv6 kerberos static-libs"
+
+RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ elibc_musl? ( sys-libs/queue-standalone )
+ app-arch/xz-utils
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ cp -r "${WORKDIR}"/tirpc "${S}"/ || die
+ local PATCHES=(
+ "${FILESDIR}"/libtirpc-1.2.5-avoid-multiple-definition.patch
+ )
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable ipv6)
+ $(use_enable kerberos gssapi)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ # libtirpc replaces rpc support in glibc, so we need it in /
+ gen_usr_ldscript -a tirpc
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto /etc
+ doins doc/netconfig
+
+ insinto /usr/include/tirpc
+ doins -r "${WORKDIR}"/tirpc/*
+
+ # makes sure that the linking order for nfs-utils is proper, as
+ # libtool would inject a libgssglue dependency in the list.
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}