aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-24 19:57:16 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-24 19:57:16 -0500
commit969d367b2bc13e8be5773b283fece463f654511c (patch)
tree4e7249f1a9b171eb92b95b0c17473a23d23edc1d
parentRemove more keywords not supported on musl (diff)
downloadmusl-969d367b2bc13e8be5773b283fece463f654511c.tar.gz
musl-969d367b2bc13e8be5773b283fece463f654511c.tar.bz2
musl-969d367b2bc13e8be5773b283fece463f654511c.zip
dev-qt/qtcore: drop libcxx libcxxabi as it breaks the dep tree
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-qt/qtcore/Manifest1
-rw-r--r--dev-qt/qtcore/metadata.xml2
-rw-r--r--dev-qt/qtcore/qtcore-5.9.2.ebuild68
-rw-r--r--dev-qt/qtcore/qtcore-5.9.3.ebuild14
4 files changed, 2 insertions, 83 deletions
diff --git a/dev-qt/qtcore/Manifest b/dev-qt/qtcore/Manifest
index 99146f9b..ae9d169c 100644
--- a/dev-qt/qtcore/Manifest
+++ b/dev-qt/qtcore/Manifest
@@ -1,4 +1,3 @@
DIST qt-everywhere-opensource-src-4.8.7.tar.gz 241075567 SHA256 e2882295097e47fe089f8ac741a95fef47e0a73a3f3cdf21b56990638f626ea0 SHA512 f9f81a2e7205e1fd05c8d923dc73244f29aa33f951fa6b7c5c8193449328b37084796b9b71ad0c317e4e6fd00017c10ea5d67b1b2032551cde00548522218125 WHIRLPOOL ad8f01172f5bdb3a3a69fe7b03862c4c411bc8d95211053ad66ed1d60a3c0577d073d1075a1e0a80b25d9b2721addda55a2967e6ccf5e194cec8d08770ac5fc2
DIST qtbase-opensource-src-5.7.1.tar.xz 44992616 SHA256 edcdf549d94d98aff08e201dcb3ca25bc3628a37b1309e320d5f556b6b66557e SHA512 0506a3a856f76e5ba182e3382a515282b6096f3900fbdc14cd5aec425105ab61922e0ada0361234387335ceb80b3c69e39cd34d75476c2946c4371e7b8c0827f WHIRLPOOL de5ff1380b3fd9cbcca741d212ac516e3f8a31366219605730cf5525a04e4efc9965a9b3cf8e99f50a2912bc7add83f61e7f90a85e176ad2830e4c1422b5d682
-DIST qtbase-opensource-src-5.9.2.tar.xz 45148744 SHA256 7fe2bb468955f633c71b3ddd3c269e68a2c4137a4e5b8dd12dcdb34cbc6d609b SHA512 a2f965871645256f3d019f71f3febb875455a29d03fccc7a3371ddfeb193b0af12394e779df05adf69fd10fe7b0d966f3915a24528ec7eb3bc36c2db6af2b6e7 WHIRLPOOL aed0b8aac590fad17b4f9067b46097e81d9991307b296428a9592d66a7c11967ee3e9a50b1d05afdeb7503470e658b016ec5af5c71e71059bd4c0d391b845f95
DIST qtbase-opensource-src-5.9.3.tar.xz 45160080 SHA256 9e7c44005e7691dc7c85165bd4510282c47f0163521f4973eab71dbdb39a9982 SHA512 256ffb8760e94c0f87790ed35e210d0c9613e14314ff442dd763cc93fbd5caa6c11c95f5d44b12a7687fb93c9f857878132cf6d76e5933f647ca7beb54b18c7c WHIRLPOOL 08ee846bcc99fe1af47febc8436c5c6772cb1dbb096fd1cd7126e708efbf53251ddff66f1d6ea2ac9091e75f38ce784d209c3c94130e7c48b9adedd01a59b7ed
diff --git a/dev-qt/qtcore/metadata.xml b/dev-qt/qtcore/metadata.xml
index cbf4db3b..34c01218 100644
--- a/dev-qt/qtcore/metadata.xml
+++ b/dev-qt/qtcore/metadata.xml
@@ -9,8 +9,6 @@
<flag name="exceptions">Add support for exceptions - like catching them
inside the event loop (recommended by upstream)</flag>
<flag name="glib">Enable <pkg>dev-libs/glib</pkg> eventloop support</flag>
- <flag name="libcxx">Link with <pkg>sys-libs/libcxx</pkg> to avoid dependency on gcc.</flag>
- <flag name="libcxxabi">Build on top of <pkg>sys-libs/libcxxabi</pkg> instead of gcc's libsupc++ (avoids depending on gcc).</flag>
<flag name="qt3support">Enable the Qt3Support libraries for Qt4. Note that
this does not mean you can compile pure Qt3 programs with Qt4.</flag>
<flag name="systemd">Enable native journald logging support</flag>
diff --git a/dev-qt/qtcore/qtcore-5.9.2.ebuild b/dev-qt/qtcore/qtcore-5.9.2.ebuild
deleted file mode 100644
index 80da91ac..00000000
--- a/dev-qt/qtcore/qtcore-5.9.2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Cross-platform application development framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
-fi
-
-IUSE="icu systemd"
-
-DEPEND="
- dev-libs/double-conversion:=
- dev-libs/glib:2
- dev-libs/libpcre2[pcre16,unicode]
- sys-libs/zlib
- icu? ( dev-libs/icu:= )
- !icu? ( virtual/libiconv )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-5.9.3-musl-iconv.patch" )
-
-QT5_TARGET_SUBDIRS=(
- src/tools/bootstrap
- src/tools/moc
- src/tools/rcc
- src/tools/qfloat16-tables
- src/corelib
- src/tools/qlalr
- doc
-)
-
-src_configure() {
- local myconf=(
- $(qt_use icu)
- $(qt_use !icu iconv)
- $(qt_use systemd journald)
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
-
- local flags=(
- ALSA CUPS DBUS EGL EGLFS EGL_X11 EVDEV FONTCONFIG FREETYPE
- HARFBUZZ IMAGEFORMAT_JPEG IMAGEFORMAT_PNG LIBPROXY MITSHM
- OPENGL OPENSSL OPENVG PULSEAUDIO SHAPE SSL TSLIB XCURSOR
- XFIXES XKB XRANDR XRENDER XSYNC ZLIB
- )
-
- for flag in ${flags[@]}; do
- cat >> "${D%/}"/${QT5_HEADERDIR}/QtCore/qconfig.h <<- _EOF_ || die
-
- #if defined(QT_NO_${flag}) && defined(QT_${flag})
- # undef QT_NO_${flag}
- #elif !defined(QT_NO_${flag}) && !defined(QT_${flag})
- # define QT_NO_${flag}
- #endif
- _EOF_
- done
-}
diff --git a/dev-qt/qtcore/qtcore-5.9.3.ebuild b/dev-qt/qtcore/qtcore-5.9.3.ebuild
index a52f1b1d..c210c684 100644
--- a/dev-qt/qtcore/qtcore-5.9.3.ebuild
+++ b/dev-qt/qtcore/qtcore-5.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~ppc ~x86"
fi
-IUSE="icu libcxx libcxxabi systemd"
+IUSE="icu systemd"
DEPEND="
dev-libs/double-conversion:=
@@ -21,11 +21,6 @@ DEPEND="
icu? ( dev-libs/icu:= )
!icu? ( virtual/libiconv )
systemd? ( sys-apps/systemd:= )
- libcxx? (
- sys-devel/clang:=
- sys-libs/libcxx:=
- libcxxabi? ( sys-libs/libcxxabi:= )
- )
"
RDEPEND="${DEPEND}"
@@ -45,15 +40,10 @@ QT5_TARGET_SUBDIRS=(
)
src_configure() {
- if use libcxxabi; then
- eapply "${FILESDIR}/${PN}-clang-libc++abi.patch"
- fi
-
local myconf=(
$(qt_use icu)
$(qt_use !icu iconv)
$(qt_use systemd journald)
- $(if use libcxx ; then echo "-platform linux-clang-libc++" ; fi)
)
qt5-build_src_configure
}