aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-06-29 14:42:29 -0700
committerAric Belsito <lluixhi@gmail.com>2018-06-29 14:42:29 -0700
commita16515e5a86fcf9aebc5c7330ca34d6faac8c8c5 (patch)
treedfa634056c13112aad51c474c299d0436e2b20e2
parentdev-util/cargo: update dependencies (diff)
downloadmusl-a16515e5a86fcf9aebc5c7330ca34d6faac8c8c5.tar.gz
musl-a16515e5a86fcf9aebc5c7330ca34d6faac8c8c5.tar.bz2
musl-a16515e5a86fcf9aebc5c7330ca34d6faac8c8c5.zip
dev-libs/appstream-glib: new package
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild67
-rw-r--r--dev-libs/appstream-glib/files/appstream-glib-0.7.9-missing-stdint_h.patch22
-rw-r--r--dev-libs/appstream-glib/metadata.xml11
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
new file mode 100644
index 00000000..5ac9a0b1
--- /dev/null
+++ b/dev-libs/appstream-glib/Manifest
@@ -0,0 +1 @@
+DIST appstream-glib-0.7.9.tar.xz 2245728 BLAKE2B fb6f54329bed91f1acaa6218b111fd4527dff7ed412a89cb44a6e4f6cdfb7e0fe4e6f9fb37b6cdc2efa75164dccef323b6d7428a63b08369b941d36b0b9071f0 SHA512 d78cb6f11cad01d67cb33f16e987485177d20b78a8b21cfbabb64ce7b18b813c0d2d1de2faeea199fdc31d12633e899a5596a6cf133cb831a4377d641f79eb7d
diff --git a/dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild b/dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild
new file mode 100644
index 00000000..bd56c70f
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +introspection stemmer"
+
+RDEPEND="
+ >=dev-libs/glib-2.45.8:2
+ sys-apps/util-linux
+ app-arch/libarchive
+ >=net-libs/libsoup-2.51.92:2.4
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+ app-arch/gcab
+
+ x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ stemmer? ( dev-libs/snowball-stemmer )
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.7
+"
+# ${PN} superseeds appdata-tools
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+PATCHES=( "${FILESDIR}/${P}-missing-stdint_h.patch" )
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ -Dfonts=true
+ $(meson_use stemmer)
+ -Dman=true
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/appstream-glib/files/appstream-glib-0.7.9-missing-stdint_h.patch b/dev-libs/appstream-glib/files/appstream-glib-0.7.9-missing-stdint_h.patch
new file mode 100644
index 00000000..fe4abc3d
--- /dev/null
+++ b/dev-libs/appstream-glib/files/appstream-glib-0.7.9-missing-stdint_h.patch
@@ -0,0 +1,22 @@
+diff -Naur appstream-glib-0.7.9.orig/client/as-util.c appstream-glib-0.7.9/client/as-util.c
+--- appstream-glib-0.7.9.orig/client/as-util.c 2018-06-29 14:38:14.133404736 -0700
++++ appstream-glib-0.7.9/client/as-util.c 2018-06-29 14:38:54.489404014 -0700
+@@ -26,6 +26,7 @@
+ #include <glib-unix.h>
+ #include <gio/gio.h>
+
++#include <stdint.h>
+ #include <appstream-glib.h>
+ #include <archive_entry.h>
+ #include <archive.h>
+diff -Naur appstream-glib-0.7.9.orig/libappstream-glib/as-utils.c appstream-glib-0.7.9/libappstream-glib/as-utils.c
+--- appstream-glib-0.7.9.orig/libappstream-glib/as-utils.c 2018-06-29 14:38:14.135404736 -0700
++++ appstream-glib-0.7.9/libappstream-glib/as-utils.c 2018-06-29 14:38:37.927404310 -0700
+@@ -33,6 +33,7 @@
+ #include "config.h"
+
+ #include <fnmatch.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <archive_entry.h>
+ #include <archive.h>
diff --git a/dev-libs/appstream-glib/metadata.xml b/dev-libs/appstream-glib/metadata.xml
new file mode 100644
index 00000000..03dc1460
--- /dev/null
+++ b/dev-libs/appstream-glib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="stemmer">Add word stemming via <pkg>dev-libs/snowball-stemmer</pkg>.</flag>
+</use>
+</pkgmetadata>