aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-11-29 11:00:49 -0800
committerAric Belsito <lluixhi@gmail.com>2017-11-29 11:00:49 -0800
commitb9f7156c27af59f3871f3f5c7c1b5440782893e2 (patch)
treee813b3c981d3de0b9a05f2e0881c46a22840cb62
parentdev-libs/DirectFB: sync use flags (diff)
downloadmusl-b9f7156c.tar.gz
musl-b9f7156c.tar.bz2
musl-b9f7156c.zip
sys-apps/iproute2: version bump to 4.14.1-r1
-rw-r--r--sys-apps/iproute2/iproute2-4.14.1-r1.ebuild (renamed from sys-apps/iproute2/iproute2-4.14.1.ebuild)7
-rw-r--r--sys-apps/iproute2/iproute2-4.4.0.ebuild9
-rw-r--r--sys-apps/iproute2/metadata.xml2
3 files changed, 10 insertions, 8 deletions
diff --git a/sys-apps/iproute2/iproute2-4.14.1.ebuild b/sys-apps/iproute2/iproute2-4.14.1-r1.ebuild
index 48f244b6..b8a34e6f 100644
--- a/sys-apps/iproute2/iproute2-4.14.1.ebuild
+++ b/sys-apps/iproute2/iproute2-4.14.1-r1.ebuild
@@ -23,7 +23,7 @@ IUSE="atm berkdb +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
!net-misc/arpd
- !minimal? ( net-libs/libmnl )
+ !minimal? ( net-libs/libmnl virtual/libelf )
iptables? ( >=net-firewall/iptables-1.4.20:= )
berkdb? ( sys-libs/db:= )
atm? ( net-dialup/linux-atm )
@@ -34,7 +34,7 @@ DEPEND="
${RDEPEND}
app-arch/xz-utils
iptables? ( virtual/pkgconfig )
- sys-devel/bison
+ >=sys-devel/bison-2.4
sys-devel/flex
>=sys-kernel/linux-headers-3.16
elibc_glibc? ( >=sys-libs/glibc-2.7 )
@@ -63,7 +63,7 @@ src_prepare() {
default
sed -i \
- -e '/^CC :=/d' \
+ -e '/^CC :\?=/d' \
-e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
-e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
@@ -104,6 +104,7 @@ src_configure() {
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_MNL := $(usex minimal n y)
+ HAVE_ELF := $(usex minimal n y)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, #144265 #293709
diff --git a/sys-apps/iproute2/iproute2-4.4.0.ebuild b/sys-apps/iproute2/iproute2-4.4.0.ebuild
index 3741d1fc..4e5b37c4 100644
--- a/sys-apps/iproute2/iproute2-4.4.0.ebuild
+++ b/sys-apps/iproute2/iproute2-4.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -22,7 +22,7 @@ IUSE="atm berkdb +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="!net-misc/arpd
- !minimal? ( net-libs/libmnl )
+ !minimal? ( net-libs/libmnl virtual/libelf )
iptables? ( >=net-firewall/iptables-1.4.20:= )
berkdb? ( sys-libs/db:= )
atm? ( net-dialup/linux-atm )
@@ -31,7 +31,7 @@ RDEPEND="!net-misc/arpd
DEPEND="${RDEPEND}
app-arch/xz-utils
iptables? ( virtual/pkgconfig )
- sys-devel/bison
+ >=sys-devel/bison-2.4
sys-devel/flex
>=sys-kernel/linux-headers-3.16
elibc_glibc? ( >=sys-libs/glibc-2.7 )"
@@ -44,7 +44,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-4.4.0-missing-limits_h.patch
sed -i \
- -e '/^CC =/d' \
+ -e '/^CC :\?=/d' \
-e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
-e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
@@ -84,6 +84,7 @@ src_configure() {
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_MNL := $(usex minimal n y)
+ HAVE_ELF := $(usex minimal n y)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, #144265 #293709
diff --git a/sys-apps/iproute2/metadata.xml b/sys-apps/iproute2/metadata.xml
index 0fa0b4cd..2605d5fd 100644
--- a/sys-apps/iproute2/metadata.xml
+++ b/sys-apps/iproute2/metadata.xml
@@ -8,6 +8,6 @@
<use>
<flag name="berkdb">build programs that use berkdb (just arpd)</flag>
<flag name="iptables">include support for iptables filtering</flag>
- <flag name="minimal">only install ip and tc programs</flag>
+ <flag name="minimal">only install ip and tc programs, without eBPF support</flag>
</use>
</pkgmetadata>