aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-08-19 05:49:00 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-08-19 05:49:00 -0400
commitc92431d2777eebaa40ebfdfc43d858bc4ccf479d (patch)
tree79abeb3c97fcc4c8896d9295fb32bf84d46756b5
parentdev-libs/glib: remove old and sync PYTHON_COMP (diff)
downloadmusl-c92431d2.tar.gz
musl-c92431d2.tar.bz2
musl-c92431d2.zip
x11-libs/libdrm: version bump to 2.4.93
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.93.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 77b11d52..a190c7af 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1 +1,2 @@
DIST libdrm-2.4.91.tar.bz2 815419 BLAKE2B 7df2a4bdb4b2708cc00b71173e7e261ab7f8645a473984a7cbda2c7073f14b7f87d53eb39cc075b743e72e4cda03b2c4fca6b9df6c7d5db2c739398a13f13f35 SHA512 07578c00c121ba37033db7172590e26d1545f81c242bbce2cfb7fb904bde504822c275d6468e5c5d20360d0046ae73d9b058aa0459ba35eb11927141cc998772
+DIST libdrm-2.4.93.tar.bz2 826579 BLAKE2B 6b2775a6bc631001be874d1337ef9607ee8ff5b86ce5e3d8ff6c6eb58182a30e2c70592cb4eb9e88c9e046d73b510f632272c57621706afd1db416acc6ce366c SHA512 ba4221e8d6a3a9872fb6d30a0ea391e30ea0e17f249c66f067bed9c2161ed1ad8083959cb2c212834c6566c3e025f4daae31e9533d77aae19bbbbb9de6c2ab3d
diff --git a/x11-libs/libdrm/libdrm-2.4.93.ebuild b/x11-libs/libdrm/libdrm-2.4.93.ebuild
new file mode 100644
index 00000000..e94d943b
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.93.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="elibc_FreeBSD? ( >=dev-libs/libpthread-stubs-0.4:=[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+PATCHES=( "${FILESDIR}"/fix-ioctl.patch )
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Udev is only used by tests now.
+ -Dudev=false
+ -Dcairo-tests=false
+ -Damdgpu=$(usex video_cards_amdgpu true false)
+ -Dexynos=$(usex video_cards_exynos true false)
+ -Dfreedreno=$(usex video_cards_freedreno true false)
+ -Dintel=$(usex video_cards_intel true false)
+ -Dnouveau=$(usex video_cards_nouveau true false)
+ -Domap=$(usex video_cards_omap true false)
+ -Dradeon=$(usex video_cards_radeon true false)
+ -Dtegra=$(usex video_cards_tegra true false)
+ -Dvc4=$(usex video_cards_vc4 true false)
+ -Detnaviv=$(usex video_cards_vivante true false)
+ -Dvmwgfx=$(usex video_cards_vmware true false)
+ -Dlibkms=$(usex libkms true false)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ -Dvalgrind=$(usex valgrind auto false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}