aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-07-18 18:48:02 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-07-18 18:57:30 -0400
commitc953aa1e70692f4b0bc89135fd3b9ba3879a8e48 (patch)
treef25b4617d127c4df90951dde09fbc21818ab2c7e
parentnet-wireless/crda: version 3.18 in the gentoo tree works. (diff)
downloadmusl-c953aa1e.tar.gz
musl-c953aa1e.tar.bz2
musl-c953aa1e.zip
gnome-base/gnome-keyring: add missing <sys/select.h>
-rw-r--r--gnome-base/gnome-keyring/Manifest4
-rw-r--r--gnome-base/gnome-keyring/files/gnome-keyring-3.14.0-musl-add-sys_select_h.patch11
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.14.0-r99.ebuild77
-rw-r--r--gnome-base/gnome-keyring/metadata.xml18
4 files changed, 110 insertions, 0 deletions
diff --git a/gnome-base/gnome-keyring/Manifest b/gnome-base/gnome-keyring/Manifest
new file mode 100644
index 00000000..00d0cb48
--- /dev/null
+++ b/gnome-base/gnome-keyring/Manifest
@@ -0,0 +1,4 @@
+AUX gnome-keyring-3.14.0-musl-add-sys_select_h.patch 504 SHA256 17abd3f7674e162c69ff0fe0138271403c4b8a67595866fff5a3272a6001ad0e SHA512 1b809e0529ad86719b6409cfb83f88bb8529c5da3ede71d5353a26123206183c05e96297c8f14658654906c9ed14505d32c6a6ef9184cc59e39877450dc81274 WHIRLPOOL b29265de7e3129bdc458c08555051c4884a800c09fb3c6e2211cf3e708c137f637a7d3d741fadeafd68a2313d26e584f9f8203743e96ccfaf62ace7759d21253
+DIST gnome-keyring-3.14.0.tar.xz 1172092 SHA256 c7059516cc47192e8bc5f1095e8e57cd3388825a4584ea8ad67a97763b7c9040 SHA512 5f8e1cd636e6293efe2b70e981efe80adc22152531530ace8d704fc2f7596c3502ff8a8ffdb1b15fa69d642d04eabd875761588f13269847116fd72416596be8 WHIRLPOOL b6913bd252697cf8822c51a93aef2501c32ed5d128947e137730d7a16722f4806e0dcefc5b452ff01a55d26a4e53126dfdba368a093f106cb13ec97ebdb58723
+EBUILD gnome-keyring-3.14.0-r99.ebuild 2092 SHA256 707cb7da895764d376ec3c26d4f9738664b452f68f827018dd6741478ab6f901 SHA512 77b6f707a509b9e477682cbe708cd981a6b8b079e67d88736cfb83e5049163746009b42f2f70f4298f591a004fb6d7fc1af9a6db80f2ce805d7c62251d77b1aa WHIRLPOOL d451e0bba41c5cbbe6dcc892c46f166ecf30342eaafa8ee0dfe319afd9880fc05d47ff4668652206644ff8e5c7255cbbc5f5f87a92e8e215c4ac609daf916132
+MISC metadata.xml 789 SHA256 77bcb7e0dbc7721e5491732fb92fba7473e9ae9b17725842270c75fe12124e5c SHA512 802568250f4e486d06a5b724deee4bc1aeab25348d58df62a37ab82f61c56ef47d69fdd853bf7ad4fcd9ce4cd8cbf174c86c1f1f6f96dc145fa40a5aaf22d299 WHIRLPOOL 6af3afe8de8b38ff7ff6a14a0fad9bc89ba498164c112a1adcbdc721d41d7e2651ddaf94de11a072eed951255f55866f8d74c813cde0f2a0db18fb7e44f945a2
diff --git a/gnome-base/gnome-keyring/files/gnome-keyring-3.14.0-musl-add-sys_select_h.patch b/gnome-base/gnome-keyring/files/gnome-keyring-3.14.0-musl-add-sys_select_h.patch
new file mode 100644
index 00000000..f6f2513c
--- /dev/null
+++ b/gnome-base/gnome-keyring/files/gnome-keyring-3.14.0-musl-add-sys_select_h.patch
@@ -0,0 +1,11 @@
+diff -Naur gnome-keyring-3.14.0.orig/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c gnome-keyring-3.14.0/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
+--- gnome-keyring-3.14.0.orig/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c 2014-09-23 03:45:13.000000000 -0400
++++ gnome-keyring-3.14.0/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c 2015-07-18 18:45:17.631673696 -0400
+@@ -34,6 +34,7 @@
+
+ #include <dlfcn.h>
+ #include <pthread.h>
++#include <sys/select.h>
+
+ #define SOCKET_PATH "/tmp/gkm-rpc-daemon.sock"
+
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.14.0-r99.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.14.0-r99.ebuild
new file mode 100644
index 00000000..c5b2cf56
--- /dev/null
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.14.0-r99.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.14.0.ebuild,v 1.9 2015/07/17 15:33:40 ago Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes" # Not gnome macro but similar
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fcaps gnome2 pam python-any-r1 versionator virtualx
+
+DESCRIPTION="Password and keyring managing daemon"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+caps debug pam selinux +ssh-agent test"
+KEYWORDS="~alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=app-crypt/gcr-3.5.3:=[gtk]
+ >=dev-libs/glib-2.38:2
+ app-misc/ca-certificates
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=sys-apps/dbus-1.1.1
+ caps? ( sys-libs/libcap-ng )
+ pam? ( virtual/pam )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-musl-add-sys_select_h.patch
+
+ # Disable stupid CFLAGS
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with caps libcap-ng) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable selinux) \
+ $(use_enable ssh-agent) \
+ --enable-doc \
+ --enable-gpg-agent
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
+}
+
+pkg_postinst() {
+ # cap_ipc_lock only needed if building --with-libcap-ng
+ # Never install as suid root, this breaks dbus activation, see bug #513870
+ use caps && fcaps -m 755 cap_ipc_lock usr/bin/gnome-keyring-daemon
+ gnome2_pkg_postinst
+}
diff --git a/gnome-base/gnome-keyring/metadata.xml b/gnome-base/gnome-keyring/metadata.xml
new file mode 100644
index 00000000..1ab41809
--- /dev/null
+++ b/gnome-base/gnome-keyring/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <longdescription lang="en">
+ GNOME Keyring is a collection of components in GNOME that store
+ secrets, passwords, keys, certificates and make them available to
+ applications. It is integrated with the user's login, so that
+ their secret storage can be unlocked when the user logins into their
+ session. It is based around a standard called PKCS#11, which is a
+ standard way for applications to manage certificates and keys on
+ smart cards or secure storage.
+ </longdescription>
+ <use>
+ <flag name="ssh-agent">Use GNOME Keyring to unlock SSH keys.
+ Recommended unless you are using ECDSA or Ed25519 keys.</flag>
+ </use>
+</pkgmetadata>