aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-02-07 23:28:18 -0800
committerAric Belsito <lluixhi@gmail.com>2018-02-07 23:28:18 -0800
commitcaa3db8329136a8500ba859bb3f920976a738176 (patch)
treebf2ab0d280e07a27736f39aa10104362c95f2cb4
parentx11-base/xorg-server: fix manifest to make travis happy (diff)
downloadmusl-caa3db83.tar.gz
musl-caa3db83.tar.bz2
musl-caa3db83.zip
sys-apps/iucode_tool: version bump to 2.3.1
-rw-r--r--sys-apps/iucode_tool/Manifest1
-rw-r--r--sys-apps/iucode_tool/iucode_tool-2.3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/iucode_tool/Manifest b/sys-apps/iucode_tool/Manifest
index ca3b4a68..1d9939d2 100644
--- a/sys-apps/iucode_tool/Manifest
+++ b/sys-apps/iucode_tool/Manifest
@@ -1,2 +1,3 @@
DIST iucode-tool_2.2.tar.xz 149896 BLAKE2B c8289541b5a1550e4eaca2dc347cfd78f04cc723c9e7ca995feb1bd8ef8130db1c595613f66ffa22487fefe20a45e51268d989cc24694e6cc1a07012a564ac68 SHA512 edb5969c1e00480e537cddc49d7cbb190ce70e6f0c44d9c40a481038bfa048fade1b454a7f4eef3048cc204ee303758fe76222f9c9fb9b407ed463ee0ccdd429
+DIST iucode-tool_2.3.1.tar.xz 153380 BLAKE2B 30dfc28e1dd4e0241cb7cfeb18bba746bb85c341a1627e21a5db4965271c26fcfe33f036c2008207bc9fa6c2f32bf2b857e78c9bf23739817d5c5c487d6010cb SHA512 2c7f72eaf509f9daa482ec5f8eb86a45ac9fa84fa856678fdf9ad056e19532e3734e04656d9dbebbd3a774d69f4c861c1340bbe67b1c6c60d61135705980e7d6
DIST iucode-tool_2.3.tar.xz 153220 BLAKE2B 4d4fddd1c479172a2bc13c4f45a9be13caf66c5ea396fe7b91df29f5ab12e8d07df0bf5d994c23fe5e9001e585a018549e210ac4669d3bcbde7913adc8aab54d SHA512 8cdbc2970d964c11e9178ef38897f88aaf770b70ad5bd4d91fa6164665b1a4e8be7aa2a4b3d7781e55c298ed9e46be0f278ffc1010feee0bd4745486edfa87fc
diff --git a/sys-apps/iucode_tool/iucode_tool-2.3.1.ebuild b/sys-apps/iucode_tool/iucode_tool-2.3.1.ebuild
new file mode 100644
index 00000000..2fd8b999
--- /dev/null
+++ b/sys-apps/iucode_tool/iucode_tool-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools eutils
+
+DESCRIPTION="tool to manipulate Intel X86 and X86-64 processor microcode update collections"
+HOMEPAGE="https://gitlab.com/iucode-tool/"
+SRC_URI="https://gitlab.com/iucode-tool/releases/raw/master/${PN/_/-}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="elibc_musl? ( sys-libs/argp-standalone )"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${PN/_/-}-${PV}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.2-limits.patch"
+ use elibc_musl && eapply "${FILESDIR}/${PN}-2.2-argp.patch"
+
+ eapply_user
+
+ eautoreconf
+}