aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2018-05-23 09:42:14 +0000
committerAnthony G. Basile <blueness@gentoo.org>2018-07-04 18:08:45 -0400
commite0f93f2f3e042cbed4b5257f39586c8b3e738452 (patch)
tree7189f934e15bd5ca10e354d53ad083f9091e9f1e
parentsys-libs/libunwind: change committed in main tree (diff)
downloadmusl-e0f93f2f.tar.gz
musl-e0f93f2f.tar.bz2
musl-e0f93f2f.zip
app-admin/hardinfo: add package
fix compiler error by renaming "stdout" struct member Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--app-admin/hardinfo/Manifest1
-rw-r--r--app-admin/hardinfo/files/hardinfo-musl.patch25
-rw-r--r--app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild27
-rw-r--r--app-admin/hardinfo/metadata.xml5
4 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/hardinfo/Manifest b/app-admin/hardinfo/Manifest
new file mode 100644
index 00000000..cc90aef3
--- /dev/null
+++ b/app-admin/hardinfo/Manifest
@@ -0,0 +1 @@
+DIST hardinfo-0.5.2_pre20130823.tar.xz 280472 BLAKE2B d72883e7e57234b3328d03daf4d81cc478b383b51f4de08981792c42b3278ede81731ca831fbc285a594aa7f00f861c870aa6d784b7c282960f5541f04f9ce45 SHA512 e36bd4eec0090461de5fdb6c17dccf76937ee8fa9cb3411068fc568847f519023037999278bbb8b9a24608ed5b1d7fd2bebfe7115c631ccca1c35fa259cb20b1
diff --git a/app-admin/hardinfo/files/hardinfo-musl.patch b/app-admin/hardinfo/files/hardinfo-musl.patch
new file mode 100644
index 00000000..70151eb5
--- /dev/null
+++ b/app-admin/hardinfo/files/hardinfo-musl.patch
@@ -0,0 +1,25 @@
+Rename struct member to fix build failure with musl:
+
+ modules/computer.c:240:27: error: expected identifier before '(' token
+ if (detect_lang[i].stdout) {
+ ^
+--- hardinfo-0.5.2_pre20130823/modules/computer.c.orig 2018-05-22 13:02:50.873031729 -0700
++++ hardinfo-0.5.2_pre20130823/modules/computer.c 2018-05-22 13:02:54.537055912 -0700
+@@ -194,7 +194,7 @@
+ gchar *compiler_name;
+ gchar *version_command;
+ gchar *regex;
+- gboolean stdout;
++ gboolean out;
+ } detect_lang[] = {
+ { "Scripting Languages", NULL, FALSE },
+ { "CPython", "python -V", "\\d+\\.\\d+\\.\\d+", FALSE },
+@@ -237,7 +237,7 @@
+ continue;
+ }
+
+- if (detect_lang[i].stdout) {
++ if (detect_lang[i].out) {
+ found = g_spawn_command_line_sync(detect_lang[i].version_command, &output, NULL, NULL, NULL);
+ } else {
+ found = g_spawn_command_line_sync(detect_lang[i].version_command, NULL, &output, NULL, NULL);
diff --git a/app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild b/app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild
new file mode 100644
index 00000000..bd12e607
--- /dev/null
+++ b/app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A system information and benchmark tool for Linux systems"
+HOMEPAGE="http://hardinfo.org/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ net-libs/libsoup
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-musl.patch
+)
diff --git a/app-admin/hardinfo/metadata.xml b/app-admin/hardinfo/metadata.xml
new file mode 100644
index 00000000..6f49eba8
--- /dev/null
+++ b/app-admin/hardinfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>