aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdupes/files/fdupes-9999-makefile.patch')
-rw-r--r--app-misc/fdupes/files/fdupes-9999-makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/fdupes/files/fdupes-9999-makefile.patch b/app-misc/fdupes/files/fdupes-9999-makefile.patch
new file mode 100644
index 00000000..b534c648
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-9999-makefile.patch
@@ -0,0 +1,28 @@
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 921d910..67576f9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -78,9 +78,9 @@ MKDIR = mkdir -p
+ # Make Configuration
+ #
+ CC ?= gcc
+-COMPILER_OPTIONS = -Wall -O -g
++CFLAGS ?= -Wall -O -g
+
+-CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
++CFLAGS += -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
+
+ INSTALL_PROGRAM = $(INSTALL) -c -m 0755
+ INSTALL_DATA = $(INSTALL) -c -m 0644
+@@ -100,7 +100,7 @@ OBJECT_FILES = fdupes.o md5/md5.o $(ADDITIONAL_OBJECTS)
+ all: fdupes
+
+ fdupes: $(OBJECT_FILES)
+- $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o fdupes $(OBJECT_FILES)
+
+ installdirs:
+ test -d $(DESTDIR)$(BIN_DIR) || $(MKDIR) $(DESTDIR)$(BIN_DIR)