summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-04-27 13:32:00 -0400
committerBrian Evans <grknight@gentoo.org>2016-04-27 13:32:00 -0400
commit34aaa33ab5930e40f746ac7c75d9c1fe5026839e (patch)
tree79fdd099cf2042c5ebd2fa6f516964388414d952
parentFix patch to work with -p1 (diff)
downloadmysql-extras-34aaa33a.tar.gz
mysql-extras-34aaa33a.tar.bz2
mysql-extras-34aaa33a.zip
Respin 2 patches for MySQL 5.7
-rw-r--r--20001_all_fix-minimal-build-cmake-mysql-5.7.patch15
-rw-r--r--20007_all_cmake-debug-werror-5.7.patch16
2 files changed, 31 insertions, 0 deletions
diff --git a/20001_all_fix-minimal-build-cmake-mysql-5.7.patch b/20001_all_fix-minimal-build-cmake-mysql-5.7.patch
new file mode 100644
index 0000000..bf21da4
--- /dev/null
+++ b/20001_all_fix-minimal-build-cmake-mysql-5.7.patch
@@ -0,0 +1,15 @@
+diff -aurwN mysql.orig/CMakeLists.txt mysql/CMakeLists.txt
+--- a/CMakeLists.txt 2014-07-18 11:48:39.000000000 -0400
++++ b/CMakeLists.txt 2014-08-01 12:54:52.612732241 -0400
+@@ -626,10 +626,10 @@
+ # scripts/mysql_config depends on client and server targets loaded above.
+ # It is referenced by some of the directories below, so we insert it here.
+ ADD_SUBDIRECTORY(scripts)
++ADD_SUBDIRECTORY(support-files)
+
+ IF(NOT WITHOUT_SERVER)
+ ADD_SUBDIRECTORY(mysql-test)
+ ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
+- ADD_SUBDIRECTORY(support-files)
+ IF(EXISTS ${CMAKE_SOURCE_DIR}/internal/CMakeLists.txt)
+ ADD_SUBDIRECTORY(internal)
diff --git a/20007_all_cmake-debug-werror-5.7.patch b/20007_all_cmake-debug-werror-5.7.patch
new file mode 100644
index 0000000..4321399
--- /dev/null
+++ b/20007_all_cmake-debug-werror-5.7.patch
@@ -0,0 +1,16 @@
+diff -aurN a/cmake/maintainer.cmake b/cmake/maintainer.cmake
+--- a/cmake/maintainer.cmake 2014-11-21 00:39:51.000000000 -0500
++++ b/cmake/maintainer.cmake 2014-12-03 13:19:50.893380789 -0500
+@@ -30,12 +30,6 @@
+ "${MY_CXX_WARNING_FLAGS} -Wno-null-conversion -Wno-unused-private-field")
+ ENDIF()
+
+-# Turn on Werror (warning => error) when using maintainer mode.
+-IF(MYSQL_MAINTAINER_MODE)
+- SET(MY_C_WARNING_FLAGS "${MY_C_WARNING_FLAGS} -Werror")
+- SET(MY_CXX_WARNING_FLAGS "${MY_CXX_WARNING_FLAGS} -Werror")
+-ENDIF()
+-
+ # Set warning flags for GCC/Clang
+ IF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${MY_C_WARNING_FLAGS}")