aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>1998-12-06 16:17:41 +0000
committerPhil Blundell <philb@gnu.org>1998-12-06 16:17:41 +0000
commitb77cd76d98cfe6087e5a05eb8ce0cee2c206d670 (patch)
tree70c216494213385b6d30001000681058c5f5df61
parentMore socket-open fixes (diff)
downloadnet-tools-b77cd76d98cfe6087e5a05eb8ce0cee2c206d670.tar.gz
net-tools-b77cd76d98cfe6087e5a05eb8ce0cee2c206d670.tar.bz2
net-tools-b77cd76d98cfe6087e5a05eb8ce0cee2c206d670.zip
Miscellaneous minor mods. Unless anything turns up in the next
day or so this will be net-tools 1.49.
-rw-r--r--Makefile2
-rw-r--r--README9
-rw-r--r--config.in5
-rw-r--r--ifconfig.c4
-rw-r--r--lib/Makefile2
-rw-r--r--lib/masq_info.c12
-rw-r--r--netstat.c4
7 files changed, 21 insertions, 17 deletions
diff --git a/Makefile b/Makefile
index adbb270..b50ec39 100644
--- a/Makefile
+++ b/Makefile
@@ -87,7 +87,7 @@ RESLIB = # -L/usr/inet6/lib -linet6
# -------- end of user definitions --------
MAINTAINER = Philip.Blundell@pobox.com
-RELEASE = 1.48
+RELEASE = 1.49
.EXPORT_ALL_VARIABLES:
diff --git a/README b/README
index 3949b20..dcec959 100644
--- a/README
+++ b/README
@@ -28,7 +28,14 @@ Contents:
Notes
-----
-This is net-tools 1.48. Notable changes since 1.47 include:
+This is net-tools 1.49. Notable changes since 1.48 include:
+
+ - IP masquerading support is now selectable.
+ - The -t and -u switches to netstat now work as expected.
+ - AX.25 support in netstat has been improved.
+ - Various other bugs have been fixed.
+
+Notable changes since 1.47 include:
- Many bugs have been fixed.
diff --git a/config.in b/config.in
index 27273d5..3fcc89e 100644
--- a/config.in
+++ b/config.in
@@ -78,3 +78,8 @@ bool 'FDDI (generic) support' HAVE_HWFDDI n
bool 'HIPPI (generic) support' HAVE_HWHIPPI n
bool 'Ash hardware support' HAVE_HWASH n
bool '(Cisco)-HDLC/LAPB support' HAVE_HWHDLCLAPB n
+*
+*
+* Other Features.
+*
+bool 'IP Masquerading support' HAVE_FW_MASQUERADE n
diff --git a/ifconfig.c b/ifconfig.c
index 05424ef..131c74b 100644
--- a/ifconfig.c
+++ b/ifconfig.c
@@ -3,7 +3,7 @@
* that either displays or sets the characteristics of
* one or more of the system's networking interfaces.
*
- * Version: $Id: ifconfig.c,v 1.24 1998/12/05 10:33:51 philip Exp $
+ * Version: $Id: ifconfig.c,v 1.25 1998/12/06 16:17:44 philip Exp $
*
* Author: Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
* and others. Copyright 1993 MicroWalt Corporation
@@ -107,7 +107,7 @@ static const char *if_port_text[][4] =
#include "sockets.h"
#include "util.h"
-char *Release = RELEASE, *Version = "ifconfig 1.36 (1998-10-31)";
+char *Release = RELEASE, *Version = "ifconfig 1.37 (1998-12-05)";
int opt_a = 0; /* show all interfaces */
int opt_i = 0; /* show the statistics */
diff --git a/lib/Makefile b/lib/Makefile
index c0e7f9c..d9815c8 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -29,7 +29,7 @@ OBJS = $(sort $(VARIA) $(AFOBJS) $(HWOBJS) \
# This can be overwritten by the TOPLEVEL Makefile
TOPDIR=..
-CFLAGS += -I$(TOPDIR) -I$(TOPDIR)/include -fPIC
+CFLAGS += -I$(TOPDIR) -I$(TOPDIR)/include # -fPIC
SONAME=libnet-tools.so.0
.SUFFIXES: .a .so
diff --git a/lib/masq_info.c b/lib/masq_info.c
index dd61a3a..a2a80af 100644
--- a/lib/masq_info.c
+++ b/lib/masq_info.c
@@ -6,7 +6,7 @@
* NET-3 Networking Distribution for the LINUX operating
* system. (net-tools, net-drivers)
*
- * Version: $Id: masq_info.c,v 1.3 1998/11/15 20:11:11 freitag Exp $
+ * Version: $Id: masq_info.c,v 1.4 1998/12/06 16:17:55 philip Exp $
*
* Author: Bernd 'eckes' Eckenfels <net-tools@lina.inka.de>
* Copyright 1999 Bernd Eckenfels, Germany
@@ -34,22 +34,14 @@
#include <malloc.h>
#include <string.h>
#include <unistd.h>
-#if 0
-#include <linux/ip.h>
-#include <linux/icmp.h>
-#include <linux/tcp.h>
-#include <linux/udp.h>
-#include <linux/if.h>
-#include <linux/ip_fw.h>
-#endif
#include "net-support.h"
#include "pathnames.h"
#include "version.h"
#include "config.h"
#include "intl.h"
#include "net-features.h"
-#if HAVE_FW_MASQUERADE
+#if HAVE_FW_MASQUERADE
struct masq {
unsigned long expires; /* Expiration timer */
diff --git a/netstat.c b/netstat.c
index 88f990f..a0c0d94 100644
--- a/netstat.c
+++ b/netstat.c
@@ -7,7 +7,7 @@
* NET-3 Networking Distribution for the LINUX operating
* system.
*
- * Version: $Id: netstat.c,v 1.13 1998/12/01 09:28:09 philip Exp $
+ * Version: $Id: netstat.c,v 1.14 1998/12/06 16:17:46 philip Exp $
*
* Authors: Fred Baumgarten, <dc6iq@insu1.etec.uni-karlsruhe.de>
* Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
@@ -101,7 +101,7 @@ typedef enum {
#define FEATURE_NETSTAT
#include "lib/net-features.h"
-char *Release = RELEASE, *Version = "netstat 1.34 (1998-06-29)", *Signature = "Fred Baumgarten <dc6iq@insu1.etec.uni-karlsruhe.de> and Alan Cox.";
+char *Release = RELEASE, *Version = "netstat 1.35 (1998-12-05)", *Signature = "Fred Baumgarten <dc6iq@insu1.etec.uni-karlsruhe.de> and Alan Cox.";
#define E_READ -1