summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorscruggsj <scruggsj@localhost>2006-07-15 18:52:20 +0000
committerscruggsj <scruggsj@localhost>2006-07-15 18:52:20 +0000
commit530a2bc59b790fb757ec08af21a58e3f470d0212 (patch)
tree58ff157f601596f7816299f9de482c51f59003a2 /net-misc/nxclient/nxclient-2.0.0.ebuild
parent* Fix xorg 7 patch for SVN FreeNX. (diff)
downloadnx-530a2bc59b790fb757ec08af21a58e3f470d0212.tar.gz
nx-530a2bc59b790fb757ec08af21a58e3f470d0212.tar.bz2
nx-530a2bc59b790fb757ec08af21a58e3f470d0212.zip
* Fixed typo in depends.
* Added the 50nxpaths file to add some environment variables. * Made some wrappers so that certain provrams get an added path that points to /usr/NX/lib. Maybe this will be better than setting LDPATH with caused lots of errors. * Might be feature complete. Needs some testing. svn path=/testing/; revision=87
Diffstat (limited to 'net-misc/nxclient/nxclient-2.0.0.ebuild')
-rw-r--r--net-misc/nxclient/nxclient-2.0.0.ebuild43
1 files changed, 32 insertions, 11 deletions
diff --git a/net-misc/nxclient/nxclient-2.0.0.ebuild b/net-misc/nxclient/nxclient-2.0.0.ebuild
index 4bb4964..9eba83e 100644
--- a/net-misc/nxclient/nxclient-2.0.0.ebuild
+++ b/net-misc/nxclient/nxclient-2.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit rpm
+inherit eutils rpm
DESCRIPTION="NXClient is a X11/VNC/NXServer client especially tuned for using remote desktops over low-bandwidth links such as the Internet"
HOMEPAGE="http://www.nomachine.com"
@@ -44,7 +44,7 @@ DEPEND=">=dev-libs/expat-1.95.8
x86? ( >=sys-libs/lib-compat-1.4 )
- || ( ( x11-libs/libx11
+ || ( ( x11-libs/libX11
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libXext
@@ -90,14 +90,35 @@ src_install() {
rm -f ${D}/usr/NX/bin/nxesd
fi
- # FIXME: Of the options in the applnk directory, the desktop files in the
- # "network" directory seem to make the most sense. I have no idea if this
- # works for KDE or just for Gnome.
- declare applnk=/usr/NX/share/applnk apps=/usr/share/applications
- if [[ -d ${D}${applnk} ]]; then
- dodir ${apps}
- mv ${D}${applnk}/network/*.desktop ${D}${apps}
- rm ${D}${apps}/nxclient-help.desktop
- rm -rf ${D}${applnk}
+ # Make wrappers to /usr/NX/lib, so other programs are not affected.
+ mv ${D}/usr/NX/bin/nxclient ${D}/usr/NX/bin/nxclient.wrapped
+ make_wrapper nxclient nxclient.wrapped /usr/NX/bin /usr/NX/lib /usr/NX/bin
+
+ if use prebuilt ; then
+ mv ${D}/usr/NX/bin/nxservice ${D}/usr/NX/bin/nxservice.wrapped
+ make_wrapper nxservice nxservice.wrapped /usr/NX/bin /usr/NX/lib /usr/NX/bin
+ mv ${D}/usr/NX/bin/nxssh ${D}/usr/NX/bin/nxssh.bin
+ make_wrapper nxssh nxssh.bin /usr/NX/bin /usr/NX/lib /usr/NX/bin
+ fi
+
+ # install environment variables
+ if use prebuilt ; then
+ cat <<EOF > ${T}/50nxpaths
+NXDIR=/usr/NX
+PATH=${NXDIR}/bin
+ROOTPATH=${NXDIR}/bin
+CONFIG_PROTECT="${NXDIR}/etc ${NXDIR}/home"
+PRELINK_PATH_MASK=${NXDIR}
+SEARCH_DIRS_MASK=/usr/NX
+EOF
+ doenvd ${T}/50nxpaths
fi
+
+ # Of the options in the applnk directory, the desktop files in the
+ # "network" directory seem to make the most sense.
+ declare applnk=/usr/NX/share/applnk
+ domenu ${D}${applink}/network/nxclient-admin.desktop \
+ ${D}${applink}/network/nxclient-wizard.desktop \
+ ${D}${applink}/network/nxclient.desktop
+ rm -rf ${D}${applnk}
}