aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-04-02 16:08:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-04-02 16:08:25 +0300
commite10d88d10cfc7da664e66cf8c5a7bf297ea4b8f7 (patch)
tree3067ff1529cb354bc23c51f61aa78251d4074da7
parentsystem-login: fix nested selinux comment (diff)
downloadpambase-e10d88d10cfc7da664e66cf8c5a7bf297ea4b8f7.tar.gz
pambase-e10d88d10cfc7da664e66cf8c5a7bf297ea4b8f7.tar.bz2
pambase-e10d88d10cfc7da664e66cf8c5a7bf297ea4b8f7.zip
add vital patches into the sourcespambase-20190402
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--Makefile4
-rw-r--r--passwd.in9
-rw-r--r--system-auth.in4
-rw-r--r--system-login.in9
4 files changed, 13 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index a459fd0..abd7008 100644
--- a/Makefile
+++ b/Makefile
@@ -32,6 +32,10 @@ ifeq "$(SYSTEMD)" "yes"
PAMFLAGS += -DHAVE_SYSTEMD=1
endif
+ifeq "$(ELOGIND)" "yes"
+PAMFLAGS += -DHAVE_ELOGIND=1
+endif
+
ifeq "$(GNOME_KEYRING)" "yes"
PAMFLAGS += -DHAVE_GNOME_KEYRING=1
endif
diff --git a/passwd.in b/passwd.in
index 7eabf3d..248bb7c 100644
--- a/passwd.in
+++ b/passwd.in
@@ -1,6 +1,7 @@
-auth sufficient pam_rootok.so
-auth include system-auth
+auth sufficient pam_rootok.so
+auth include system-auth
-account include system-auth
+account include system-auth
-password include system-auth
+password include system-auth
+-password optional pam_gnome_keyring.so UNIX_AUTHTOK
diff --git a/system-auth.in b/system-auth.in
index c729004..4d588fb 100644
--- a/system-auth.in
+++ b/system-auth.in
@@ -39,3 +39,7 @@ session optional pam_ssh.so
#if HAVE_SYSTEMD
-session optional pam_systemd.so
#endif
+
+#if HAVE_ELOGIND
+-session optional pam_elogind.so
+#endif
diff --git a/system-login.in b/system-login.in
index 137c40c..064c687 100644
--- a/system-login.in
+++ b/system-login.in
@@ -8,9 +8,6 @@ auth required pam_shells.so DEBUG
auth required pam_nologin.so DEBUG_NOLOGIN
#endif
auth include system-auth
-#if HAVE_GNOME_KEYRING
-auth optional pam_gnome_keyring.so
-#endif
#if HAVE_ACCESS
account required pam_access.so DEBUG
@@ -27,9 +24,6 @@ account required TALLY_MODULE onerr=succeed DEBUG
#endif
password include system-auth
-#if HAVE_GNOME_KEYRING
-password optional pam_gnome_keyring.so
-#endif
#if HAVE_LOGINUID
session optional pam_loginuid.so
@@ -51,9 +45,6 @@ session optional pam_ck_connector.so nox11
# Note: modules that run in the user's context must come after this line.
session required pam_selinux.so multiple open
#endif
-#if HAVE_GNOME_KEYRING
-session optional pam_gnome_keyring.so auto_start
-#endif
#if HAVE_MOTD
session optional pam_motd.so motd=/etc/motd
#endif