aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-06 06:43:34 +0000
committerSam James <sam@gentoo.org>2023-01-06 06:55:04 +0000
commit654de6dd526dc660faadee393f9de7bfc049c23f (patch)
tree19985607da9ea4ce4c2ea382b79fb0b90a83f31a
parenttravis: drop (diff)
downloadpax-utils-654de6dd.tar.gz
pax-utils-654de6dd.tar.bz2
pax-utils-654de6dd.zip
CI: Add ASAN, UBSAN to CI
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--.github/workflows/build-test-ci.yml10
1 files changed, 4 insertions, 6 deletions
diff --git a/.github/workflows/build-test-ci.yml b/.github/workflows/build-test-ci.yml
index 52c0ee1..18c13f0 100644
--- a/.github/workflows/build-test-ci.yml
+++ b/.github/workflows/build-test-ci.yml
@@ -3,12 +3,7 @@
name: Build+Test CI
-on:
- push:
- branches: [master, gh-actions]
- tags: [v*]
- pull_request:
- types: [created, opened, edited]
+on: [pull_request, push]
jobs:
make:
@@ -17,11 +12,13 @@ jobs:
os: [ubuntu-latest]
cc: [gcc, clang]
bb: [meson, muon]
+ sanitizer: [none, address, undefined]
fail-fast: false
runs-on: ${{ matrix.os }}
env:
CC: ${{ matrix.cc }}
BB: ${{ matrix.bb }}
+ SANITIZER: ${{ matrix.sanitizer }}
steps:
- name: Install dependencies
run: |
@@ -53,6 +50,7 @@ jobs:
-Dbuild_manpages=disabled \
-Dtests=true \
-Duse_fuzzing=true \
+ -Db_sanitize="${SANITIZER}" \
build
ninja -C build
( cd build && "$BB" test; )