aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-25 00:09:46 +0530
committerMike Frysinger <vapier@gentoo.org>2016-11-12 02:10:03 -0500
commit9ae5c22341a0484319c15d12cae1a46835c48379 (patch)
treea4ad7c8f02865184507b8651940e730bf3daae45 /Makefile
parentsplit out fs related helper funcs as lib code (diff)
downloadpax-utils-9ae5c22341a0484319c15d12cae1a46835c48379.tar.gz
pax-utils-9ae5c22341a0484319c15d12cae1a46835c48379.tar.bz2
pax-utils-9ae5c22341a0484319c15d12cae1a46835c48379.zip
split out ld.so.cache & ld.so.conf parsing logic
These are getting a bit big & unwieldy for keeping inlined in scanelf. Split them out to a dedicated file instead.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 91b1536..569e924 100644
--- a/Makefile
+++ b/Makefile
@@ -66,7 +66,7 @@ override CPPFLAGS += -DVCSID='"$(VCSID)"'
####################################################################
ELF_TARGETS = scanelf dumpelf $(shell echo | $(CC) -dM -E - | grep -q __svr4__ || echo pspax)
-ELF_OBJS = paxelf.o
+ELF_OBJS = paxelf.o paxldso.o
MACH_TARGETS = scanmacho
MACH_OBJS = paxmacho.o
COMMON_OBJS = paxinc.o security.o xfuncs.o