aboutsummaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-10 03:44:27 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-10 03:44:27 +0000
commitb6bc2e5e23b9f077f1cafdf6c53f301261ac5541 (patch)
treebea1545ef4723fece5048412ea594159677fc33b /man
parentcut usage and insert note about required docbook packages (diff)
downloadpax-utils-b6bc2e5e23b9f077f1cafdf6c53f301261ac5541.tar.gz
pax-utils-b6bc2e5e23b9f077f1cafdf6c53f301261ac5541.tar.bz2
pax-utils-b6bc2e5e23b9f077f1cafdf6c53f301261ac5541.zip
add custom xsl fragment to eat newlines in linsts
Diffstat (limited to 'man')
-rw-r--r--man/Makefile2
-rw-r--r--man/custom.xsl21
-rw-r--r--man/scanelf.docbook2
3 files changed, 23 insertions, 2 deletions
diff --git a/man/Makefile b/man/Makefile
index 5acd642..36d4fad 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -1,7 +1,7 @@
man_XMANS = dumpelf.1 pspax.1 scanelf.1
all:
- xmlto man pax-utils.docbook
+ xmlto man -x custom.xsl pax-utils.docbook
distclean:
rm -f $(man_XMANS)
diff --git a/man/custom.xsl b/man/custom.xsl
new file mode 100644
index 0000000..bf01b14
--- /dev/null
+++ b/man/custom.xsl
@@ -0,0 +1,21 @@
+<?xml version="1.0"?>
+<xsl:stylesheet
+xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
+
+ <xsl:import
+ href="http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl" />
+
+ <xsl:template match="itemizedlist/listitem">
+ <xsl:text>&#x2022;&#10;</xsl:text>
+ <xsl:apply-templates/>
+ <xsl:if test="following-sibling::listitem">
+ <xsl:text>.sp -1&#10;</xsl:text>
+ <xsl:text>.TP</xsl:text>
+ <xsl:if test="not($list-indent = '')">
+ <xsl:text> </xsl:text>
+ <xsl:value-of select="$list-indent"/>
+ </xsl:if>
+ <xsl:text>&#10;</xsl:text>
+ </xsl:if>
+ </xsl:template>
+</xsl:stylesheet>
diff --git a/man/scanelf.docbook b/man/scanelf.docbook
index 60759f3..731d2b5 100644
--- a/man/scanelf.docbook
+++ b/man/scanelf.docbook
@@ -203,7 +203,7 @@
<para>
And there are a number of conversion specifiers. We try to match up the
specifier with corresponding option.
- <itemizedlist spacing="compact">
+ <itemizedlist>
<listitem><para><emphasis remap='B'>a</emphasis> - machine (EM) type</para></listitem>
<listitem><para><emphasis remap='B'>b</emphasis> - bind flags</para></listitem>
<listitem><para><emphasis remap='B'>e</emphasis> - program headers</para></listitem>